summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5anya2020-04-28 04:09:01 +0300
committer5anya2020-04-28 04:09:01 +0300
commitb5afc2223ec14a160c7ce1380aa6eb9c74dd9644 (patch)
tree6887725b2af275003c404d843181d76401313f22
parentc183f2fed2b9b5b1c8175ad1e050a12d46fc7bfe (diff)
downloadaur-b5afc2223ec14a160c7ce1380aa6eb9c74dd9644.tar.gz
rename game directory to avoid conflict with base game
-rw-r--r--PKGBUILD11
-rw-r--r--gog-crypt-of-the-necrodancer-amplified2
-rw-r--r--gog-crypt-of-the-necrodancer-amplified.desktop12
-rw-r--r--gog-crypt-of-the-necrodancer-amplified.install22
4 files changed, 23 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fc7c29bed6f..a29edd36dda7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: 5anya <sanya at national dot shitposting dot agency>
# Contributor: Luke Chen <doomer at yahoo dot com>
pkgname=gog-crypt-of-the-necrodancer-amplified
-_pkgname=crypt-of-the-necrodancer
+_pkgname=crypt-of-the-necrodancer-amplified
epoch=1
pkgver=1.29.14917
_pkgver=1_29_14917
_dlcver=2_59_21255
-pkgrel=1
+pkgrel=1.1
pkgdesc="A roguelike rhythm game! (with the Amplified DLC)"
-conflicts=('gog-crypt-of-the-necrodancer')
arch=('i686' 'x86_64')
license=('custom')
install=${pkgname}.install
@@ -19,9 +18,9 @@ source=("local://crypt_of_the_necrodancer_en_${_pkgver}.sh"
"$pkgname.install")
sha256sums=(SKIP
SKIP
- 'd80562a04ded4b25bca9738267d1d93d2be8fef74570aa7d00d83471c4e71121'
- '9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89'
- '99136db3939cbab2ae33181479e069c3d25298096758327a41d002494c8ae54c')
+ '070ec64e6d5bc1a4b68e73fd25a716b116b279718b338f071f0bea953532d4ff'
+ '1542f20660e4bf1fc78a35759a71d6d658d3b80279fe5223fc0d60f25d309f0e'
+ 'bf6f3b593bfeef411cc0ff660bd2f469a41b14e1b5b4176f748cc70bf58a64e4')
PKGEXT=".pkg.tar"
package() {
diff --git a/gog-crypt-of-the-necrodancer-amplified b/gog-crypt-of-the-necrodancer-amplified
index b73e863dbe12..90d8f033ddef 100644
--- a/gog-crypt-of-the-necrodancer-amplified
+++ b/gog-crypt-of-the-necrodancer-amplified
@@ -1,4 +1,4 @@
#!/bin/bash
-gogdir="/opt/gog/crypt-of-the-necrodancer"
+gogdir="/opt/gog/crypt-of-the-necrodancer-amplified"
"$gogdir"/start.sh
diff --git a/gog-crypt-of-the-necrodancer-amplified.desktop b/gog-crypt-of-the-necrodancer-amplified.desktop
index f216ff991535..d76d221f109e 100644
--- a/gog-crypt-of-the-necrodancer-amplified.desktop
+++ b/gog-crypt-of-the-necrodancer-amplified.desktop
@@ -2,11 +2,11 @@
Encoding=UTF-8
Value=1.0
Type=Application
-Name=Crypt of the NecroDancer
-GenericName=Crypt of the NecroDancer
-Comment=Crypt of the NecroDancer
-Icon=/opt/gog/crypt-of-the-necrodancer/support/icon.png
-Exec="/opt/gog/crypt-of-the-necrodancer/start.sh"
+Name=Crypt of the NecroDancer Amplified
+GenericName=Crypt of the NecroDancer Amplified
+Comment=Crypt of the NecroDancer Amplified
+Icon=/opt/gog/crypt-of-the-necrodancer-amplified/support/icon.png
+Exec="/opt/gog/crypt-of-the-necrodancer-amplified/start.sh"
Categories=Game;
-Path=/opt/gog/crypt-of-the-necrodancer
+Path=/opt/gog/crypt-of-the-necrodancer-amplified
diff --git a/gog-crypt-of-the-necrodancer-amplified.install b/gog-crypt-of-the-necrodancer-amplified.install
index cf19d24aae8e..66e2bbf3d040 100644
--- a/gog-crypt-of-the-necrodancer-amplified.install
+++ b/gog-crypt-of-the-necrodancer-amplified.install
@@ -1,13 +1,13 @@
post_install() {
- touch /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
- touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
- touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
- mkdir /opt/gog/crypt-of-the-necrodancer/game/replays/
- mkdir /opt/gog/crypt-of-the-necrodancer/game/logs/
- chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
- chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
- chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
- chmod 777 /opt/gog/crypt-of-the-necrodancer/game/replays/
- chmod 777 /opt/gog/crypt-of-the-necrodancer/game/logs/
- echo "==> The save is located in /opt/gog/crypt-of-the-necrodancer/game/data/"
+ touch /opt/gog/crypt-of-the-necrodancer-amplified/game/data/played.dat
+ touch /opt/gog/crypt-of-the-necrodancer-amplified/game/data/save_data.xml
+ touch /opt/gog/crypt-of-the-necrodancer-amplified/game/data/save_data.xml_TEMP
+ mkdir /opt/gog/crypt-of-the-necrodancer-amplified/game/replays/
+ mkdir /opt/gog/crypt-of-the-necrodancer-amplified/game/logs/
+ chmod 666 /opt/gog/crypt-of-the-necrodancer-amplified/game/data/played.dat
+ chmod 666 /opt/gog/crypt-of-the-necrodancer-amplified/game/data/save_data.xml
+ chmod 666 /opt/gog/crypt-of-the-necrodancer-amplified/game/data/save_data.xml_TEMP
+ chmod 777 /opt/gog/crypt-of-the-necrodancer-amplified/game/replays/
+ chmod 777 /opt/gog/crypt-of-the-necrodancer-amplified/game/logs/
+ echo "==> The save is located in /opt/gog/crypt-of-the-necrodancer-amplified/game/data/"
}