summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoJoS2015-06-21 00:47:04 +0200
committerJoJoS2015-06-21 00:47:04 +0200
commitf46f5523d9ed23b40c3a79741570476be901399c (patch)
treee5459e307c488c458321cdefd5eabdf374af2f54
downloadaur-gog-deponia.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rwxr-xr-xgog-deponia5
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..203db2346d89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gog-deponia
+ pkgdesc = Rufus is not a pleasant guy. Ill-tempered and entirely too convinced of his own greatness, he lives at the edge of a small settlement somewhere in the most remote sector of the garbage-covered planet Deponia. GOG linux game package required!
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/deponia
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = desktop-file-utils
+ source = local://gog_deponia_1.0.0.1.tar.gz
+ source = gog-deponia
+ md5sums = eecdcdceef7baf7095a2c0737dc6dd56
+ md5sums = df28238a567d876ba67383efb7754fe5
+
+pkgname = gog-deponia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2d0346c8193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : JoJos
+
+pkgname=gog-deponia
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Rufus is not a pleasant guy. Ill-tempered and entirely too convinced of his own greatness, he lives at the edge of a small settlement somewhere in the most remote sector of the garbage-covered planet Deponia. GOG linux game package required!"
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/deponia"
+license=("custom")
+groups=("games")
+source=("local://gog_deponia_${pkgver}.tar.gz" "gog-deponia")
+md5sums=('eecdcdceef7baf7095a2c0737dc6dd56'
+ 'df28238a567d876ba67383efb7754fe5')
+depends=(libgl libx11 libxext desktop-file-utils)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/deponia
+ cp -r "${srcdir}"/Deponia/* "${pkgdir}"/opt/gog/deponia
+ install -Dm644 "${srcdir}"/Deponia/support/gog-deponia-primary.desktop "${pkgdir}"/usr/share/applications/gog-deponia.desktop
+ install -Dm644 "${srcdir}"/Deponia/support/gog-deponia.png "${pkgdir}"/usr/share/pixmaps/gog-deponia.png
+ install -Dm644 "${srcdir}"/Deponia/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-deponia" "${pkgdir}/usr/bin/gog-deponia"
+}
diff --git a/gog-deponia b/gog-deponia
new file mode 100755
index 000000000000..533cb0a5b22f
--- /dev/null
+++ b/gog-deponia
@@ -0,0 +1,5 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/deponia"
+
+"$gogdir"/start.sh
+