summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-06-06 20:25:38 -0500
committerDan Beste2017-06-06 20:25:38 -0500
commitd6d66146587ffa1ad674a857e9de27e158445bd4 (patch)
treebb0939217ce3b85e36e4dd9cc64ffac4e1c011b6
parentf4537d89c304e6d15d613c7ba1d8eae421140e9b (diff)
downloadaur-d6d66146587ffa1ad674a857e9de27e158445bd4.tar.gz
v2.6.0.8
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD88
-rw-r--r--gog-dont-starve24
4 files changed, 88 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a700484ae91..1ad50c085d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Dec 16 03:44:59 UTC 2015
pkgbase = gog-dont-starve
pkgdesc = An uncompromising wilderness survival game full of science and magic
- pkgver = 2.1.0.3
- pkgrel = 2
+ pkgver = 2.6.0.8
+ pkgrel = 1
url = https://www.kleientertainment.com/games/dont-starve
- arch = i686
arch = x86_64
license = custom
- depends = sdl2
- depends = libcurl-gnutls
optdepends = gog-dont-starve-rog: Reign of Giants DLC
- source = gog://gog_don_t_starve_2.1.0.3.sh
+ optdepends = gog-dont-starve-shipwrecked: Shipwrecked DLC
+ source = gog-dont-starve
source = gog-dont-starve.desktop
- sha256sums = 8f8fca4d89626e43f4ee2d378cc30daf2a45c24c91a3bc1694d83a00fb0a062b
+ source = file://gog_don_t_starve_2.6.0.8.sh
+ sha256sums = 9827bed58903e8a351b4f52f4728b37c6e7b31abb206f2fff99e1467ae967179
sha256sums = 609856aae2d19877f8afb764a8db15a8932e535b719cc342f4b42c3d0e4b1956
+ sha256sums = 6cb3f1572f7b1d25d7b561cab7b144b3ad8ade0b84a9b5dbcfdaf42ede5cc28d
pkgname = gog-dont-starve
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..41eae4b3dc78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!gog-dont-starve
+!gog-dont-starve.desktop
diff --git a/PKGBUILD b/PKGBUILD
index ffd47c04b0b7..6771bd662750 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,59 @@
-# Maintainer: Ainola
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Contributor: Ainola
-pkgname=gog-dont-starve
-pkgver=2.1.0.3
-pkgrel=2
+# Notes:
+# + gog:// DLAGENT:
+# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
+# automatically pull game files from GOG.
+# - https://github.com/Sude-/lgogdownloader
+
+pkgname='gog-dont-starve'
+pkgver=2.6.0.8
+pkgrel=1
pkgdesc="An uncompromising wilderness survival game full of science and magic"
-url="https://www.kleientertainment.com/games/dont-starve"
+url='https://www.kleientertainment.com/games/dont-starve'
license=('custom')
-arch=('i686' 'x86_64')
-depends=('sdl2' 'libcurl-gnutls')
-optdepends=('gog-dont-starve-rog: Reign of Giants DLC')
-source=("gog://gog_don_t_starve_${pkgver}.sh"
- "${pkgname}.desktop")
-sha256sums=('8f8fca4d89626e43f4ee2d378cc30daf2a45c24c91a3bc1694d83a00fb0a062b'
- '609856aae2d19877f8afb764a8db15a8932e535b719cc342f4b42c3d0e4b1956')
-
-# You need to download the gog.com installer file manually or with lgogdownloader.
-DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
-
-# Prevent compressing final package
-PKGEXT='.pkg.tar'
-
-prepare(){
- cd "$srcdir/data/noarch"
- [ $CARCH == "x86" ] && rm -r "game/dontstarve64"
- [ $CARCH == "x86_64" ] && rm -r "game/dontstarve32"
- # The launcher expects the user to be in the game dir
- echo -e "#!/bin/sh\ncd /opt/${pkgname}\n./start.sh" > "${srcdir}/${pkgname}"
-}
+arch=('x86_64')
+optdepends=(
+ 'gog-dont-starve-rog: Reign of Giants DLC'
+ 'gog-dont-starve-shipwrecked: Shipwrecked DLC'
+)
+source=(
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "file://gog_don_t_starve_${pkgver}.sh"
+)
+sha256sums=(
+ '9827bed58903e8a351b4f52f4728b37c6e7b31abb206f2fff99e1467ae967179'
+ '609856aae2d19877f8afb764a8db15a8932e535b719cc342f4b42c3d0e4b1956'
+ '6cb3f1572f7b1d25d7b561cab7b144b3ad8ade0b84a9b5dbcfdaf42ede5cc28d'
+)
package(){
- cd "$srcdir"
- # Install game
+ cd "${srcdir}"
+
install -d "${pkgdir}/opt/${pkgname}/"
- install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/opt/${pkgname}/support/"
install -d "${pkgdir}/usr/bin/"
- cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
- install -Dm755 "data/noarch/start.sh" \
- "${pkgdir}/opt/${pkgname}/"
- install -Dm755 data/noarch/support/*.{sh,shlib} -t \
- "${pkgdir}/opt/${pkgname}/support"
- # Desktop integration
- install -Dm 644 "data/noarch/support/icon.png" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ cp -r data/noarch/game/ "${pkgdir}/opt/${pkgname}/"
+
+ install -D -m 755 \
+ "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 755 \
+ data/noarch/start.sh \
+ "${pkgdir}/opt/${pkgname}/"
+ install -D -m 755 \
+ data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support/"
+ install -D -m 644 \
+ 'data/noarch/docs/End User License Agreement.txt' \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ install -D -m 644 \
+ "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m 644 \
+ "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/gog-dont-starve b/gog-dont-starve
new file mode 100644
index 000000000000..6ff8f500da39
--- /dev/null
+++ b/gog-dont-starve
@@ -0,0 +1,24 @@
+#! /bin/bash
+
+pkgname='gog-dont-starve'
+pkgdir="/opt/${pkgname}/"
+run="${pkgdir}/start.sh"
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ "${run}"
+ fi
+else
+ "${run}"
+fi