summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-06-06 20:31:46 -0500
committerDan Beste2017-06-06 20:31:46 -0500
commit456f0d56a9bb5df2e99c5247d75619d9e2444f73 (patch)
tree0d7e6cdc64c4399fceef729f32101016853529a3
downloadaur-456f0d56a9bb5df2e99c5247d75619d9e2444f73.tar.gz
v2.3.0.5
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39c35eb7e61a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gog-dont-starve-shipwrecked
+ pkgdesc = Don't Starve: Shipwrecked DLC
+ pkgver = 2.3.0.5
+ pkgrel = 1
+ url = https://www.kleientertainment.com/games/dont-starve
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gog-dont-starve
+ source = file://gog_don_t_starve_shipwrecked_dlc_2.3.0.5.sh
+ sha256sums = 1a06da5546803c9c8b17f99b876362dec8fc8c85ec26277d10011879ffd19267
+
+pkgname = gog-dont-starve-shipwrecked
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9865d22ba8ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a07f67512a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Contributor: Ainola
+
+# Notes:
+# + gog:// DLAGENT:
+# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
+# automatically pull game files from GOG.
+# - https://github.com/Sude-/lgogdownloader
+
+pkgname='gog-dont-starve-shipwrecked'
+pkgver=2.3.0.5
+pkgrel=1
+pkgdesc="Don't Starve: Shipwrecked DLC"
+url="https://www.kleientertainment.com/games/dont-starve"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('gog-dont-starve')
+source=(
+ "file://gog_don_t_starve_shipwrecked_dlc_${pkgver}.sh"
+)
+sha256sums=(
+ '1a06da5546803c9c8b17f99b876362dec8fc8c85ec26277d10011879ffd19267'
+)
+
+package(){
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/opt/gog-dont-starve/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/gog-dont-starve/"
+}