summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Seering2015-07-18 11:30:07 +0200
committerStefan Seering2015-07-18 11:30:07 +0200
commit0d71d40552c0efb0c13926c5d36dea23b6efa754 (patch)
tree51dc13ae869e4878d63c4e3d2942314b90725be8
downloadaur-0d71d40552c0efb0c13926c5d36dea23b6efa754.tar.gz
initial package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ce63366940e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gog-dustforce-dx
+ pkgdesc = A fast-paced 2D action platforming game. As an acrobatic janitor, you are an adept force against dust and disorder. Leap and dash off walls and ceilings, and deftly traverse precarious environments. GOG Version. Linux native.
+ pkgver = 1.2.0.4
+ pkgrel = 1
+ url = https://www.gog.com/game/dustforce_dx
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = mesa
+ depends = libgl
+ depends = sdl2
+ depends = libxdamage
+ depends = libidn
+ depends = libvorbis
+ depends = libxft
+ depends = xdg-utils
+ depends = curl
+ depends = openal
+ source = gog://gog_dustforce_dx_1.2.0.4.tar.gz
+ sha256sums = 0f8225af92fa797738d04e288863c23ca625acda72ac25cfd0a1eef064e205d4
+
+pkgname = gog-dustforce-dx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba3e4f02bf9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Stefan Seering <stefanarch@gmx.de>
+_pkgname_whithout_prefix=dustforce-dx
+pkgname=gog-${_pkgname_whithout_prefix}
+pkgver=1.2.0.4
+pkgrel=1
+pkgdesc='A fast-paced 2D action platforming game. As an acrobatic janitor, you are an adept force against dust and disorder. Leap and dash off walls and ceilings, and deftly traverse precarious environments. GOG Version. Linux native.'
+arch=('i686' 'x86_64')
+license=('custom')
+url='https://www.gog.com/game/dustforce_dx'
+depends=('mesa' 'libgl' 'sdl2' 'libxdamage' 'libidn' 'libvorbis' 'libxft' 'xdg-utils' 'curl' 'openal')
+source=('gog://gog_dustforce_dx_1.2.0.4.tar.gz')
+DLAGENTS+=("gog::/usr/bin/echo Could not find %u. Manually download it to \"$(pwd)\" from https://www.gog.com/")
+sha256sums=('0f8225af92fa797738d04e288863c23ca625acda72ac25cfd0a1eef064e205d4')
+
+package() {
+ cd -- "${srcdir}/Dustforce DX"
+ rm -R -- game/lib game/lib64 # do use system libraries instead of the ones shipped with the game
+
+ mkdir -p -- "${pkgdir}/usr/share/pixmaps"
+ mv -- 'support/gog-dustforce-dx.png' "${pkgdir}/usr/share/pixmaps"
+
+ mkdir -p -- "${pkgdir}/usr/share/applications"
+ sed -i "s/Exec=gog-dustforce-dx/Exec=${_pkgname_whithout_prefix}/" -- 'support/gog-dustforce-dx-primary.desktop'
+ mv -- 'support/gog-dustforce-dx-primary.desktop' "${pkgdir}/usr/share/applications/${_pkgname_whithout_prefix}.desktop"
+
+ mkdir -p -- "${pkgdir}/usr/bin"
+ ln -s -- "/opt/gog/${_pkgname_whithout_prefix}/start.sh" "${pkgdir}/usr/bin/${_pkgname_whithout_prefix}"
+
+ mkdir -p -- "${pkgdir}/opt/gog/${_pkgname_whithout_prefix}"
+ sed -i -e '12 cdeclare -r CURRENT_DIR=/opt/gog/dustforce-dx' start.sh # the original start.sh wouldn't find the correct current dir if called via a symlink
+ cp -- start.sh "${pkgdir}/opt/gog/${_pkgname_whithout_prefix}"
+ cp -R -- support "${pkgdir}/opt/gog/${_pkgname_whithout_prefix}"
+ cp -R -- game "${pkgdir}/opt/gog/${_pkgname_whithout_prefix}"
+ cp -R -- docs "${pkgdir}/opt/gog/${_pkgname_whithout_prefix}"
+}
+