summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Zhu2017-05-23 12:32:37 -0500
committerJames Zhu2017-05-23 12:32:37 -0500
commit25203dbe35f7fd638a217de33591d6491fdbae58 (patch)
tree8a97cda658f4b3cf14dc8b6c92a362374e8a08ce
downloadaur-25203dbe35f7fd638a217de33591d6491fdbae58.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD56
-rw-r--r--gog-ftl.desktop8
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d68f6fe13e23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue May 23 17:29:41 UTC 2017
+pkgbase = gog-ftl
+ pkgdesc = Spaceship simulation roguelike. Take your ship and crew on an adventure through a randomly generated galaxy filled with glory and bitter defeat.
+ pkgver = 2.0.0.2
+ pkgrel = 1
+ url = http://subsetgames.com/ftl.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl2
+ source = gog://gog_ftl_advanced_edition_2.0.0.2.sh
+ source = gog-ftl.desktop
+ sha256sums = bda9a40e1ce857eaa9102fe9c0ec405d94c8a120657b5fab29315e70f63cc5ae
+ sha256sums = e78e5e92de0677770ecbc981acccef10766bcb3c384b50da60a3dfa3b217de16
+
+pkgname = gog-ftl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cbd05167c7a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.sh
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b579c998f247
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: James Zhu <james.zhu.engineer@gmail.com>
+
+pkgname=gog-ftl
+_name=gog-ftl-advanced-edition
+pkgver=2.0.0.2
+pkgrel=1
+pkgdesc="Spaceship simulation roguelike-like (GOG version). Take your ship and crew through a randomly generated galaxy filled with glory and bitter defeat."
+url="http://subsetgames.com/ftl.html"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('sdl2')
+source=("gog://${_name//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop")
+sha256sums=('bda9a40e1ce857eaa9102fe9c0ec405d94c8a120657b5fab29315e70f63cc5ae'
+ 'e78e5e92de0677770ecbc981acccef10766bcb3c384b50da60a3dfa3b217de16')
+
+PKGEXT='.pkg.tar'
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+prepare(){
+ # Unzip will produce an error code because it is unable to unzip the Installer.
+ # Therefore, a conditional into a no-op command will keep the PKGBUILD from failing
+ # Of course, if you have any real problems unzipping the PKGBUILD will not abort.
+ unzip "${_name//-/_}_${pkgver}.sh" || :
+ cd "${srcdir}/data/noarch"
+
+ sed -r -i \
+ 's/(CURRENT_DIR="\$\( cd "\$\( dirname )'`
+ `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
+ `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
+ "start.sh"
+}
+
+package(){
+ cd "${srcdir}/data/noarch"
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "game/" "${pkgdir}/opt/${pkgname}/"
+ chmod -R 666 "${pkgdir}/opt/${pkgname}/game/data/resources/"
+ install -Dm755 "start.sh" "${pkgdir}/opt/${pkgname}/"
+ install -Dm644 "gameinfo" "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 support/*.{sh,shlib} -t "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ ln -s "/opt/${pkgname}/start.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gog-ftl.desktop b/gog-ftl.desktop
new file mode 100644
index 000000000000..3c85300a6b76
--- /dev/null
+++ b/gog-ftl.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=FTL: Faster Than Light
+Exec=gog-ftl
+Icon=gog-ftl
+Type=Application
+Categories=Game;StrategyGame;