summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4censord2021-03-27 18:42:18 +0100
committerDaniel Koschützki2021-03-27 18:44:49 +0100
commitc7eda1652118f0f3ef6c8314ac230eda82d83a26 (patch)
tree14fee4dba15bb167fcb16134d8d849c82511e697
parent86cfc1aa3cc5a4a13408d297cf06b318572eb040 (diff)
downloadaur-c7eda1652118f0f3ef6c8314ac230eda82d83a26.tar.gz
The folder /opt/gog-hacknet/Content/People needs to be writable to create new profiles
The actual profile are saved in $HOME/.local/share/Hacknet
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce3080a5db10..3788b8baddf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-hacknet
- pkgdesc = Story driven Hacking Game
+ pkgdesc = Story driven Hacking Game (GOG version)
pkgver = 5.069
- pkgrel = 1
+ pkgrel = 2
url = https://www.gog.com/game/hacknet
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a3a32638acdf..3297acb27779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gog-hacknet
pkgver=5.069
-pkgrel=1
+pkgrel=2
pkgdesc="Story driven Hacking Game (GOG version)"
url="https://www.gog.com/game/hacknet"
license=('custom')
@@ -28,10 +28,16 @@ package(){
mkdir -p "${pkgdir}/opt/$pkgname"
cp -a "${srcdir}/data/noarch/game" -T "${pkgdir}/opt/$pkgname"
chmod -R 644 "${pkgdir}/opt/$pkgname/"
+ # required to be writable for creating new accounts, if not it fails with a exeption
+ # doesnt seem to be actually written to.
+ chmod -R 666 "${pkgdir}/opt/$pkgname/Content/People"
+
find ${pkgdir} -type d -exec chmod +x {} +
chmod 555 "${pkgdir}/opt/$pkgname/Hacknet.bin.x86_64"
chmod 555 "${pkgdir}/opt/$pkgname/Hacknet.bin.x86"
+
+
# remove integrated libsdl2 and libsdl2-image because it doesnt launch for me using them.
# deleting them makes the dynamic linker use the system libs
rm "${pkgdir}/opt/gog-hacknet/lib64/libSDL2-2.0.so.0"
@@ -39,6 +45,7 @@ package(){
rm "${pkgdir}/opt/gog-hacknet/lib/libSDL2-2.0.so.0"
rm "${pkgdir}/opt/gog-hacknet/lib/libSDL2_image-2.0.so.0"
+
# Desktop integration
install -Dm 644 "${srcdir}/data/noarch/support/icon.png" \
"${pkgdir}/usr/share/pixmaps/${pkgname}.png"