summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-05-28 17:37:42 -0500
committerDan Beste2017-05-28 17:39:06 -0500
commitaca50776ab38ae89bcc83ef3478572d5426c3685 (patch)
treeafcef64b935bd7b56996f865e98ebad0b6567091
downloadaur-aca50776ab38ae89bcc83ef3478572d5426c3685.tar.gz
Init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD64
-rw-r--r--gog-hollow-knight24
-rw-r--r--gog-hollow-knight.desktop10
5 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea641443bccb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-hollow-knight
+ pkgdesc = Hollow Knight is a challenging 2D action-adventure. You’ll explore twisting caverns, battle tainted creatures and escape intricate traps, all to solve an ancient long-hidden mystery.
+ pkgver = 2.1.0.2
+ pkgrel = 1
+ url = http://hollowknight.com/
+ arch = x86_64
+ groups = games
+ groups = gog
+ license = custom
+ source = gog-hollow-knight
+ source = gog-hollow-knight.desktop
+ source = file://gog_hollow_knight_2.1.0.2.sh
+ sha256sums = 5cd14be9e18be6277fc0daa39dd416d78d4e4445fe8998d3ddcf37a201a843b0
+ sha256sums = 8860a0daf52181f78711c2b1099d7a09a30ba09331c68e8aae71182a996a0acd
+ sha256sums = 43dc222d72979456296d1fc944cc7041758f13fa5e77a4d48c7f8772ddb95bb6
+
+pkgname = gog-hollow-knight
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e5e17c262ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!gog-hollow-knight
+!gog-hollow-knight.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05285ed9febd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Current maintainer(s):
+# - Dan Beste <dan.ray.beste@gmail.com>
+# Previously:
+# - N/A
+
+# Current contributor(s):
+# - None
+# Previously:
+# - N/A
+
+# Notes:
+# + gog:// DLAGENT:
+# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
+# automatically pull game files from GOG.
+# - https://github.com/Sude-/lgogdownloader
+
+pkgname='gog-hollow-knight'
+pkgver=2.1.0.2
+pkgrel=1
+pkgdesc="Hollow Knight is a challenging 2D action-adventure. You’ll explore twisting caverns, battle tainted creatures and escape intricate traps, all to solve an ancient long-hidden mystery."
+url='http://hollowknight.com/'
+license=('custom')
+groups=('games' 'gog')
+arch=('x86_64')
+source=(
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "file://${pkgname//-/_}_${pkgver}.sh"
+)
+sha256sums=(
+ '5cd14be9e18be6277fc0daa39dd416d78d4e4445fe8998d3ddcf37a201a843b0'
+ '8860a0daf52181f78711c2b1099d7a09a30ba09331c68e8aae71182a996a0acd'
+ '43dc222d72979456296d1fc944cc7041758f13fa5e77a4d48c7f8772ddb95bb6'
+)
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support/"
+ install -d "${pkgdir}/usr/bin/"
+
+ cp -r data/noarch/game/ "${pkgdir}/opt/${pkgname}/"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+
+ install -D -m 755 \
+ "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 755 \
+ data/noarch/start.sh \
+ "${pkgdir}/opt/${pkgname}/"
+ install -D -m 755 \
+ data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support/"
+ install -D -m 644 \
+ 'data/noarch/docs/End User License Agreement.txt' \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m 644 \
+ "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m 644 \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/gog-hollow-knight b/gog-hollow-knight
new file mode 100644
index 000000000000..7e1175b8e385
--- /dev/null
+++ b/gog-hollow-knight
@@ -0,0 +1,24 @@
+#! /bin/bash
+
+pkgname='gog-hollow-knight'
+pkgdir="/opt/${pkgname}/"
+run="${pkgdir}/start.sh"
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ "${run}"
+ fi
+else
+ "${run}"
+fi
diff --git a/gog-hollow-knight.desktop b/gog-hollow-knight.desktop
new file mode 100644
index 000000000000..d8c1c3b7eb7a
--- /dev/null
+++ b/gog-hollow-knight.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Hollow Knight
+Comment=Hollow Knight is a challenging 2D action-adventure. You’ll explore twisting caverns, battle tainted creatures and escape intricate traps, all to solve an ancient long-hidden mystery.
+Exec=gog-hollow-knight
+Icon=gog-hollow-knight
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8