summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorItrimel2020-08-18 16:08:38 +0200
committerItrimel2020-08-18 16:08:38 +0200
commit34a50f52ea30288ad356afdc38f1ab39ac7d0a48 (patch)
tree6bf7f2c855336261bf8aee12a89454d8396367bc
downloadaur-34a50f52ea30288ad356afdc38f1ab39ac7d0a48.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD58
-rw-r--r--gog-into-the-breach.desktop9
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d16dc003d783
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gog-into-the-breach
+ pkgdesc = Mecha turn based strategy game (GOG version)
+ pkgver = 1.2.24.38624
+ pkgrel = 1
+ url = http://subsetgames.com/itb.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl2
+ source = gog://into_the_breach_1_2_24_38624.sh
+ source = gog-into-the-breach.desktop
+ sha256sums = 16dce36cc511b4a838dda27384dbe662a25612dc1187d2ec7f1336f9d95b32d5
+ sha256sums = f1217b1fa26bf9fa1cf4c3f6fce23bc7f989e0d1396adfad8f5d0a6d31b5eaef
+
+pkgname = gog-into-the-breach
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..919dd4bddf87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Théo Martel <marteltheo@gmail.com>
+# Heavily borrowed from James Zhu's GOG packages
+
+pkgname=gog-into-the-breach
+_name=into-the-breach
+pkgver=1.2.24.38624
+pkgrel=1
+pkgdesc="Mecha turn based strategy game (GOG version)"
+url="http://subsetgames.com/itb.html"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('sdl2')
+source=("gog://${_name//-/_}_${pkgver//./_}.sh"
+ "${pkgname}.desktop")
+sha256sums=('16dce36cc511b4a838dda27384dbe662a25612dc1187d2ec7f1336f9d95b32d5'
+ 'f1217b1fa26bf9fa1cf4c3f6fce23bc7f989e0d1396adfad8f5d0a6d31b5eaef')
+
+PKGEXT='.pkg.tar'
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+prepare(){
+ # Unzip will produce an error code because it is unable to unzip the Installer.
+ # Therefore, a conditional into a no-op command will keep the PKGBUILD from failing
+ # Of course, if you have any real problems unzipping the PKGBUILD will not abort.
+ unzip "${_name//-/_}_${pkgver}.sh" || :
+ cd "${srcdir}/data/noarch"
+
+ sed -r -i \
+ 's/(CURRENT_DIR="\$\( cd "\$\( dirname )'`
+ `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
+ `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
+ "start.sh"
+}
+
+package(){
+ cd "${srcdir}/data/noarch"
+ # Install game
+ install -d "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/"
+ install -d "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "game/" "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/"
+ chmod -R 666 "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/game/resources/"
+ install -Dm755 "start.sh" "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/"
+ install -Dm644 "gameinfo" "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/"
+ install -Dm755 support/*.{sh,shlib} -t "${pkgdir}/home/theo/Windows-data/Jeux/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ ln -s "/home/theo/Windows-data/Jeux/${pkgname}/start.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
+
diff --git a/gog-into-the-breach.desktop b/gog-into-the-breach.desktop
new file mode 100644
index 000000000000..2f407f7d12ca
--- /dev/null
+++ b/gog-into-the-breach.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Into the Breach
+Description=Mecha turn-based startegy game
+Exec=gog-into-the-breach
+Icon=gog-into-the-breach
+Type=Application
+Categories=Game;StrategyGame;