summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182021-05-21 15:28:51 +0200
committerLukas18182021-05-21 15:28:51 +0200
commitf6a7620d67f429ac6cb6ca26af674d34e971dd18 (patch)
tree2c568735d21965683d91df3548adc88d63919745
downloadaur-f6a7620d67f429ac6cb6ca26af674d34e971dd18.tar.gz
init
-rw-r--r--.SRCINFO22
-rwxr-xr-xKingdoms and Castles.desktop8
-rw-r--r--PKGBUILD34
-rw-r--r--start-kingdoms-and-castles.sh8
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a30d734472
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gog-kingdoms-and-castles
+ pkgdesc = Kingdoms and Castles is a game about growing a kingdom from a tiny hamlet to a sprawling city and imposing castle
+ pkgver = 117r7
+ pkgrel = 1
+ url = https://www.gog.com/game/kingdoms_castles
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = lgogdownloader
+ depends = bash
+ depends = gtk2
+ depends = gtk3
+ depends = lib32-gdk-pixbuf2
+ source = kingdoms_and_castles_117r7.sh::gogdownloader://2067763543/en3installer0
+ source = start-kingdoms-and-castles.sh
+ source = Kingdoms and Castles.desktop
+ sha512sums = 5e2bd652f119501b82525a82a089e35e0f13d6cf2ef68402e2e9e6612bca6912da7eccb8a971b9a4396b4aa90b3345f78cd409fcfc256ce59cd1d1efcb34bad1
+ sha512sums = a928e02a78abab18fbe49e600ba5fb1d19b577df109fe3d9d5800c92210263a9e11b0bf1a8abac8ed1b773d57a4595f7f711344cfefa575f525d58c8d25277ba
+ sha512sums = 3f8c7438f09b670e8a34ff4efb5f3c6c5031c78492eff05a0ccadf6e60252b540ae8fd4682f84cc51a49b3db9389e0690a6ff6d6c9d01502f5f16683eb487247
+
+pkgname = gog-kingdoms-and-castles
+
diff --git a/Kingdoms and Castles.desktop b/Kingdoms and Castles.desktop
new file mode 100755
index 000000000000..6294b06b9c82
--- /dev/null
+++ b/Kingdoms and Castles.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Kingdoms and Castles
+Exec=kingdoms-and-castles
+Comment=Kingdoms and Castles is a game about growing a kingdom from a tiny hamlet to a sprawling city and imposing castle
+Terminal=false
+Icon=gog-kingdoms-and-castles.png
+Type=Application
+Categories=Game;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56ba02b3ea8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=gog-kingdoms-and-castles
+pkgver=117r7
+pkgrel=1
+pkgdesc="Kingdoms and Castles is a game about growing a kingdom from a tiny hamlet to a sprawling city and imposing castle"
+arch=('i686' 'x86_64')
+url="https://www.gog.com/game/kingdoms_castles"
+license=('custom')
+makedepends=('lgogdownloader')
+depends=('bash' 'gtk2' 'gtk3' 'lib32-gdk-pixbuf2')
+source=("kingdoms_and_castles_${pkgver//./_}.sh::gogdownloader://2067763543/en3installer0"
+ "start-kingdoms-and-castles.sh"
+ "Kingdoms and Castles.desktop")
+sha512sums=('5e2bd652f119501b82525a82a089e35e0f13d6cf2ef68402e2e9e6612bca6912da7eccb8a971b9a4396b4aa90b3345f78cd409fcfc256ce59cd1d1efcb34bad1'
+ 'a928e02a78abab18fbe49e600ba5fb1d19b577df109fe3d9d5800c92210263a9e11b0bf1a8abac8ed1b773d57a4595f7f711344cfefa575f525d58c8d25277ba'
+ '3f8c7438f09b670e8a34ff4efb5f3c6c5031c78492eff05a0ccadf6e60252b540ae8fd4682f84cc51a49b3db9389e0690a6ff6d6c9d01502f5f16683eb487247')
+
+DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/$pkgname"
+ mv "${srcdir}/data/noarch/game/KingdomsAndCastles_Data" "${pkgdir}/opt/$pkgname"
+ chmod -R 644 "${pkgdir}/opt/$pkgname/"
+ mkdir -p "${pkgdir}/opt/$pkgname/KingdomsAndCastles_Data/mods" #game does not start if folder does not exist
+ find "${pkgdir}/opt/$pkgname" -type d -exec chmod 755 {} \;
+ install -Dm 755 "${srcdir}/data/noarch/game/KingdomsAndCastles.x86" "${pkgdir}/opt/$pkgname/KingdomsAndCastles.x86"
+ install -Dm 755 "${srcdir}/data/noarch/game/KingdomsAndCastles.x86_64" "${pkgdir}/opt/$pkgname/KingdomsAndCastles.x86_64"
+ install -Dm 755 "${srcdir}/start-kingdoms-and-castles.sh" "${pkgdir}/usr/bin/kingdoms-and-castles"
+ install -Dm 755 "${srcdir}/Kingdoms and Castles.desktop" "$pkgdir/usr/share/applications/Kingdoms and Castles.desktop"
+ install -Dm 644 "${srcdir}/data/noarch/support/icon.png" "${pkgdir}/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "${srcdir}/data/noarch/docs/End User License Agreement.txt" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/start-kingdoms-and-castles.sh b/start-kingdoms-and-castles.sh
new file mode 100644
index 000000000000..20be52a3d168
--- /dev/null
+++ b/start-kingdoms-and-castles.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/gog-kingdoms-and-castles"
+if [ $(uname -m) == "x86_64" ]
+then
+ /opt/gog-kingdoms-and-castles/KingdomsAndCastles.x86_64
+else
+ /opt/gog-kingdoms-and-castles/KingdomsAndCastles.x86
+fi