summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-06-10 19:50:00 +0200
committerAndré Fettouhi2015-06-10 19:50:00 +0200
commit0b3a8af554abc3104412ae3f7de4f5244f76c85c (patch)
tree364617cf7349b03051776040d8a2f0295d02bafa
downloadaur-0b3a8af554abc3104412ae3f7de4f5244f76c85c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
-rw-r--r--gog-legend-of-grimrock4
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b8ded4f7d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gog-legend-of-grimrock
+ pkgdesc = Explore a vast network of ancient tunnels, discover secrets, and find a way to survive in the perilous dungeons of Mount Grimrock.
+ pkgver = 1.0.0.3
+ pkgrel = 1
+ url = http://www.gog.com/game/legend_of_grimrock
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = desktop-file-utils
+ source = local://legend_of_grimrock_1.0.0.3.tar.gz
+ source = gog-legend-of-grimrock
+ sha256sums = a788b20caaffca65fa111cd1b145391f6fdbb28b76ba0b99f96fcfd73b7fd946
+ sha256sums = f5e9f95e55ab87c46033606c28cea3c76ff0a4367fa0dd671070b28a9be78130
+
+pkgname = gog-legend-of-grimrock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa5da3e81c4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+
+pkgname=gog-legend-of-grimrock
+pkgver=1.0.0.3
+pkgrel=1
+pkgdesc="Explore a vast network of ancient tunnels, discover secrets, and find a way to survive in the perilous dungeons of Mount Grimrock."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/legend_of_grimrock"
+license=("custom")
+groups=("games")
+source=("local://legend_of_grimrock_${pkgver}.tar.gz" "gog-legend-of-grimrock")
+sha256sums=('a788b20caaffca65fa111cd1b145391f6fdbb28b76ba0b99f96fcfd73b7fd946'
+ 'f5e9f95e55ab87c46033606c28cea3c76ff0a4367fa0dd671070b28a9be78130')
+depends=(libgl libx11 libxext desktop-file-utils)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/legend-of-grimrock
+ cp -r "${srcdir}"/Legend\ of\ Grimrock/* "${pkgdir}"/opt/gog/legend-of-grimrock
+ install -Dm644 "${srcdir}"/Legend\ of\ Grimrock/support/gog-legend-of-grimrock-primary.desktop "${pkgdir}"/usr/share/applications/gog-legend-of-grimrock.desktop
+ install -Dm644 "${srcdir}"/Legend\ of\ Grimrock/support/gog-legend-of-grimrock.png "${pkgdir}"/usr/share/pixmaps/gog-legend-of-grimrock.png
+ install -Dm644 "${srcdir}"/Legend\ of\ Grimrock/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-legend-of-grimrock" "${pkgdir}/usr/bin/gog-legend-of-grimrock"
+}
diff --git a/gog-legend-of-grimrock b/gog-legend-of-grimrock
new file mode 100644
index 000000000000..a8708af32982
--- /dev/null
+++ b/gog-legend-of-grimrock
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/legend-of-grimrock"
+
+"$gogdir"/start.sh