summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2018-04-14 09:59:08 -0500
committerDan Beste2018-04-14 10:02:40 -0500
commit4efcfe7b7b1d183bf7ff1f4948397b2f813e20ea (patch)
tree283c19a91adce54fd594a337e25d8aebcfe7ba7e
parentcce1dec05c106c847df3322335f59476423f1829 (diff)
downloadaur-gog-owlboy.tar.gz
Restrict group write access to _only_ ini files
See PKGBUILD notes for details.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b975b334547c..861b537a7dda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-owlboy
pkgdesc = Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!
pkgver = 1.3.6564.30139
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://www.owlboygame.com/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 508e3acb4a3b..cf3935b20610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,16 @@
# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
# automatically pull game files from GOG.
# - https://github.com/Sude-/lgogdownloader
+#
+# + v1.3.6564.30139:
+# - User must be part of the 'games' system group, as for some unknown
+# reason, users must have access to the "global" game ini files in
+# addition to those in "${XDG_CONFIG_HOME}"...
+
pkgname='gog-owlboy'
pkgver=1.3.6564.30139
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!"
url="http://www.owlboygame.com/"
@@ -59,11 +65,11 @@ package() {
# Plebians...
while read -r ini; do
+ # Don't even get me started on why the fuck I have to do this...
+ chgrp games "${ini}"
chmod g+w "${ini}"
file "${ini}" | grep -Ei 'CRLF' && dos2unix "${ini}"
done < <(find "${pkgdir}" -name *.ini)
- # Don't even get me started on why the fuck I have to do this...
- chgrp -R games "${pkgdir}"
}
# vim: ts=2 sw=2 et: