summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-24 11:08:34 -0500
committerDan Beste2017-04-24 11:08:34 -0500
commitcf6a4b97f1530fd19096b58219cbc047ada204ad (patch)
tree80f00af49524fd6d25739a17c0ed6b2d7b7e2fb9
parent502b718e3ec935333caf5daece93e382227b51a8 (diff)
downloadaur-cf6a4b97f1530fd19096b58219cbc047ada204ad.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD38
2 files changed, 6 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41196bcbbff0..1b331c844726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,8 @@ pkgbase = gog-owlboy
license = custom
depends = libogg
depends = libvorbis
- depends = mojoshader-git
depends = openal
depends = sdl2
- depends = xnafiledialog-git
optdepends = firejail: Automatically sandbox this application from your OS
source = gog://gog_owlboy_2.0.0.1.sh
source = gog-owlboy.desktop
@@ -23,8 +21,6 @@ pkgbase = gog-owlboy
depends_i686 = lib32-libvorbis
depends_i686 = lib32-openal
depends_i686 = lib32-sdl2
- depends_i686 = mojoshader-git
- depends_i686 = xnafiledialog-git
pkgname = gog-owlboy
diff --git a/PKGBUILD b/PKGBUILD
index 6e3d23ed5c84..8f75dc13bb45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,16 @@
-# Maintainer: Krakn - Dan.Ray.Beste@gmail.com
-# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
# All dependencies are included with the gog_owlboy_$version.sh file.
-# For good measure I was able to track all but 2 down:
-# libmojoshader - https://icculus.org/mojoshader/
-# libXNAFileDialog - https://github.com/flibitijibibo/XNAFileDialog
-pkgname=gog-owlboy
+pkgname='gog-owlboy'
pkgver=2.0.0.1
pkgrel=1
pkgdesc="Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!"
url="http://www.owlboygame.com/"
-license=(
- 'custom'
-)
-arch=(
- 'i686'
- 'x86_64'
-)
-depends_x86_64=(
- 'libogg'
- 'libvorbis'
- 'mojoshader-git'
- 'openal'
- 'sdl2'
- 'xnafiledialog-git'
-)
-depends_i686=(
- 'lib32-libogg'
- 'lib32-libvorbis'
- 'lib32-openal'
- 'lib32-sdl2'
- 'mojoshader-git'
- 'xnafiledialog-git'
-)
+license=('custom')
+arch=('i686' 'x86_64')
+depends_x86_64=('libogg' 'libvorbis' 'openal' 'sdl2')
+depends_i686=('lib32-libogg' 'lib32-libvorbis' 'lib32-openal' 'lib32-sdl2')
optdepends=(
'firejail: Automatically sandbox this application from your OS'
)
@@ -52,15 +29,12 @@ DLAGENTS=(
)
package(){
- cd "${srcdir}"
-
# Install game
install -d "${pkgdir}/opt/${pkgname}/"
install -d "${pkgdir}/opt/${pkgname}/support"
install -d "${pkgdir}/usr/bin/"
cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
-
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
install -Dm755 "data/noarch/start.sh" \
"${pkgdir}/opt/${pkgname}/"