summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyndair2023-01-19 23:08:20 +0000
committerkyndair2023-01-19 23:08:20 +0000
commit67f56f73dbd9a0f110cecbf02eafc962b0154e84 (patch)
treed0715dd6f207d1cf843af201e6f33fd73a614ec2
downloadaur-67f56f73dbd9a0f110cecbf02eafc962b0154e84.tar.gz
initial upload
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7273b3419d21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gog-pillars_of_eternity_ii_deadfire_the_forgotten_sanctum_dlc
+ pkgdesc = DLC for the pillars of eternity ii deadfire game.
+ pkgver = 5.0.0.0040
+ pkgrel = 1
+ url = https://www.gog.com/en/game/pillars_of_eternity_ii_deadfire_the_forgotten_sanctum
+ arch = x86_64
+ license = custom
+ depends = gog-pillars_of_eternity_ii_deadfire
+ source = pillars_of_eternity_ii_deadfire_the_forgotten_sanctum_v5_0_0_0040_29222.sh::gog://pillars_of_eternity_ii_deadfire_the_forgotten_sanctum_v5_0_0_0040_29222.sh
+ sha256sums = d755a0e8a70ed7b0c756a65899141e1e992a0a5b25ce8bbe244b8bc55153c9bd
+
+pkgname = gog-pillars_of_eternity_ii_deadfire_the_forgotten_sanctum_dlc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c37a4850734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+# Place the gog installation file in the same folder as this PKGBUILD
+pkgname=gog-pillars_of_eternity_ii_deadfire_the_forgotten_sanctum_dlc
+_dlcparent=pillars_of_eternity_ii_deadfire
+_pkgname=pillars_of_eternity_ii_deadfire_the_forgotten_sanctum
+pkgver=5.0.0.0040
+_pkgver=v5_0_0_0040
+_build=29222
+pkgrel=1
+pkgdesc="DLC for the $(echo ${_dlcparent} | sed 's/_/ /g') game."
+arch=('x86_64')
+url="https://www.gog.com/en/game/pillars_of_eternity_ii_deadfire_the_forgotten_sanctum"
+license=('custom')
+depends=($(echo gog-${_dlcparent}))
+source=("${_pkgname}_${_pkgver}_${_build}.sh::gog://${_pkgname}_${_pkgver}_${_build}.sh")
+# don't download anything via makepkg
+DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+sha256sums=('d755a0e8a70ed7b0c756a65899141e1e992a0a5b25ce8bbe244b8bc55153c9bd')
+
+package() {
+ # install goggame files
+ find "${srcdir}/data/noarch/game/PillarsOfEternityII_Data" -type d -exec chmod 755 {} +
+ find "${srcdir}/data/noarch/game/PillarsOfEternityII_Data" -type f -exec chmod 644 {} +
+ mkdir -p "${pkgdir}/opt/${_dlcparent}"
+ mv "${srcdir}/data/noarch/game/PillarsOfEternityII_Data" "${pkgdir}/opt/${_dlcparent}"
+}