summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas Creager2016-07-23 08:27:00 -0400
committerDouglas Creager2016-07-23 08:27:00 -0400
commit48770ecc213e0c433cebd8038f2b60447e17e64b (patch)
tree90f79b0e3b8a0268b1d285b8f3a0f693c88c91cf
parentbc5e88217d46eb957ac6afe8f483261ffcda8233 (diff)
downloadaur-48770ecc213e0c433cebd8038f2b60447e17e64b.tar.gz
gog-qfg1 2.1.0.33-4
- Add desktop entry to run EGA version of game (which was already being installed)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--gog-qfg1-ega.desktop11
-rw-r--r--run-qfg1-ega.conf6
-rwxr-xr-xrun-qfg1-ega.sh12
5 files changed, 48 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f99923651756..6c8700d9be73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gog-qfg1
pkgdesc = Quest for Glory 1: So You Want to Be a Hero
pkgver = 2.1.0.33
- pkgrel = 3
+ pkgrel = 4
url = https://www.gog.com/game/quest_for_glory
arch = x86_64
license = custom
@@ -13,11 +13,17 @@ pkgbase = gog-qfg1
source = local://gog-qfg1.desktop
source = local://run-qfg1.conf
source = local://run-qfg1.sh
+ source = local://gog-qfg1-ega.desktop
+ source = local://run-qfg1-ega.conf
+ source = local://run-qfg1-ega.sh
sha256sums = 728aec4488c22aa43be8a362f9100b6fa63e14bf492aacb70d088199f4baf0f0
sha256sums = 81af12e1292b6ef70ea03a8dbfd42ee7ade79da36a7ebfa5765ed3baa4809a2d
sha256sums = 80baf0c3984902d4e7b3a1e4b1c76e3bf3fa1f7077de6c0c21b9ab1a406a85bc
sha256sums = 10e4bbf6562aee29c3258d482fc482f43b7d5304e84da5a31204610a2bb7990d
sha256sums = 626dc2363536802d402e8f1144182dd3ba1eb39a103efbdaa6e95a078d025e95
+ sha256sums = aeb5c003a0b0e25001a2ade14ff5a575845e73c67887e518765d49c57e59c226
+ sha256sums = b18cf12d144301de3445f2f9013c1c84dc56c9d3ff591f63b1fe00eadd87b41d
+ sha256sums = 42f2f68dca93cc92da30fb3a6f020b166174bcb0dfdb522321821fb9e1e31d74
pkgname = gog-qfg1
diff --git a/PKGBUILD b/PKGBUILD
index a96f13051a8c..3ca9158d6edd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Douglas Creager <dcreager@dcreager.net>
pkgname=gog-qfg1
pkgver=2.1.0.33
-pkgrel=3
+pkgrel=4
pkgdesc="Quest for Glory 1: So You Want to Be a Hero"
arch=('x86_64')
url="https://www.gog.com/game/quest_for_glory"
@@ -12,12 +12,18 @@ source=("local://setup_quest_for_glory_vga_2.1.0.33.exe"
"local://RESOURCE.CFG"
"local://gog-qfg1.desktop"
"local://run-qfg1.conf"
- "local://run-qfg1.sh")
+ "local://run-qfg1.sh"
+ "local://gog-qfg1-ega.desktop"
+ "local://run-qfg1-ega.conf"
+ "local://run-qfg1-ega.sh")
sha256sums=('728aec4488c22aa43be8a362f9100b6fa63e14bf492aacb70d088199f4baf0f0'
'81af12e1292b6ef70ea03a8dbfd42ee7ade79da36a7ebfa5765ed3baa4809a2d'
'80baf0c3984902d4e7b3a1e4b1c76e3bf3fa1f7077de6c0c21b9ab1a406a85bc'
'10e4bbf6562aee29c3258d482fc482f43b7d5304e84da5a31204610a2bb7990d'
- '626dc2363536802d402e8f1144182dd3ba1eb39a103efbdaa6e95a078d025e95')
+ '626dc2363536802d402e8f1144182dd3ba1eb39a103efbdaa6e95a078d025e95'
+ 'aeb5c003a0b0e25001a2ade14ff5a575845e73c67887e518765d49c57e59c226'
+ 'b18cf12d144301de3445f2f9013c1c84dc56c9d3ff591f63b1fe00eadd87b41d'
+ '42f2f68dca93cc92da30fb3a6f020b166174bcb0dfdb522321821fb9e1e31d74')
prepare() {
innoextract setup_quest_for_glory_vga_2.1.0.33.exe
@@ -29,11 +35,14 @@ package() {
rm -rf "${pkgdir}/opt/gog/qfg1/DOSBOX"
cp -R "run-qfg1.conf" "${pkgdir}/opt/gog/qfg1"
cp -R "run-qfg1.sh" "${pkgdir}/opt/gog/qfg1"
+ cp -R "run-qfg1-ega.conf" "${pkgdir}/opt/gog/qfg1"
+ cp -R "run-qfg1-ega.sh" "${pkgdir}/opt/gog/qfg1"
# Config file that tells game to use SB instead of Roland MIDI for music
cp -R "RESOURCE.CFG" "${pkgdir}/opt/gog/qfg1"
mkdir -p "${pkgdir}/usr/share/applications"
cp "gog-qfg1.desktop" "${pkgdir}/usr/share/applications"
+ cp "gog-qfg1-ega.desktop" "${pkgdir}/usr/share/applications"
}
# vim:set ts=2 sw=2 et:
diff --git a/gog-qfg1-ega.desktop b/gog-qfg1-ega.desktop
new file mode 100644
index 000000000000..cc5f7662220b
--- /dev/null
+++ b/gog-qfg1-ega.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=2.1.0.33
+Type=Application
+Name=Quest for Glory 1 (EGA)
+GenericName=Quest for Glory 1 (EGA)
+Comment=Quest for Glory 1 (original EGA version)
+Icon=/opt/gog/qfg1/goggame-1207661313.ico
+Exec=/opt/gog/qfg1/run-qfg1-ega.sh
+Categories=Game;
+Path=/opt/gog/qfg1
diff --git a/run-qfg1-ega.conf b/run-qfg1-ega.conf
new file mode 100644
index 000000000000..9c0d519f7ea8
--- /dev/null
+++ b/run-qfg1-ega.conf
@@ -0,0 +1,6 @@
+[autoexec]
+mount C .
+c:
+cd ega
+sciv.exe
+exit
diff --git a/run-qfg1-ega.sh b/run-qfg1-ega.sh
new file mode 100755
index 000000000000..9fc6923c7d8e
--- /dev/null
+++ b/run-qfg1-ega.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+set -e
+homedir="$HOME/.local/share/gog/qfg"
+gogdir="/opt/gog/qfg1"
+rundir="$XDG_RUNTIME_DIR/gog/qfg1"
+mkdir -p "$homedir"
+mkdir -p "$rundir"
+/usr/bin/unionfs "$homedir=RW:$gogdir=RO" "$rundir"
+cd "$rundir"
+/usr/bin/dosbox -conf "$gogdir/dosboxQG1VGA.conf" -conf "$gogdir/run-qfg1-ega.conf"
+cd "$gogdir"
+/usr/bin/fusermount -u "$rundir"