summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas Creager2016-07-05 09:45:28 -0400
committerDouglas Creager2016-07-05 09:45:28 -0400
commitddda3efda71a87b211b1cf1e2e08fa8d55a8e56e (patch)
tree1fc210642564ae3675e896043eb994c7ffab56a5
downloadaur-ddda3efda71a87b211b1cf1e2e08fa8d55a8e56e.tar.gz
gog-qfg1 2.1.0.33-1
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
-rw-r--r--RESOURCE.CFG11
-rw-r--r--gog-qfg1.desktop11
-rw-r--r--run-qfg1.conf4
-rwxr-xr-xrun-qfg1.sh12
7 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fa4f4d2fa44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gog-qfg1
+ pkgdesc = Quest for Glory 1: So You Want to Be a Hero
+ pkgver = 2.1.0.33
+ pkgrel = 1
+ url = https://www.gog.com/game/quest_for_glory
+ arch = x86_64
+ license = custom
+ makedepends = innoextract
+ depends = dosbox
+ depends = unionfs-fuse
+ source = local://setup_quest_for_glory_vga_2.1.0.33.exe
+ source = local://RESOURCE.CFG
+ source = local://gog-qfg1.desktop
+ source = local://run-qfg1.conf
+ source = local://run-qfg1.sh
+ sha256sums = 728aec4488c22aa43be8a362f9100b6fa63e14bf492aacb70d088199f4baf0f0
+ sha256sums = 81af12e1292b6ef70ea03a8dbfd42ee7ade79da36a7ebfa5765ed3baa4809a2d
+ sha256sums = 80baf0c3984902d4e7b3a1e4b1c76e3bf3fa1f7077de6c0c21b9ab1a406a85bc
+ sha256sums = 1fed72d017ec186e00bc386da0d1044b0088e4a09f6a6f725756cb79ff6529c3
+ sha256sums = 6324d9de9f8dc4a15211cbe3d0e4dfe58ae0bf47dbb29778c59928fe084eceb6
+
+pkgname = gog-qfg1
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb8e8eae9309
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+setup_*.exe
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..173fdb1d5132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Douglas Creager <dcreager@dcreager.net>
+pkgname=gog-qfg1
+pkgver=2.1.0.33
+pkgrel=1
+pkgdesc="Quest for Glory 1: So You Want to Be a Hero"
+arch=('x86_64')
+url="https://www.gog.com/game/quest_for_glory"
+license=('custom')
+depends=('dosbox' 'unionfs-fuse')
+makedepends=('innoextract')
+source=("local://setup_quest_for_glory_vga_2.1.0.33.exe"
+ "local://RESOURCE.CFG"
+ "local://gog-qfg1.desktop"
+ "local://run-qfg1.conf"
+ "local://run-qfg1.sh")
+sha256sums=('728aec4488c22aa43be8a362f9100b6fa63e14bf492aacb70d088199f4baf0f0'
+ '81af12e1292b6ef70ea03a8dbfd42ee7ade79da36a7ebfa5765ed3baa4809a2d'
+ '80baf0c3984902d4e7b3a1e4b1c76e3bf3fa1f7077de6c0c21b9ab1a406a85bc'
+ '1fed72d017ec186e00bc386da0d1044b0088e4a09f6a6f725756cb79ff6529c3'
+ '6324d9de9f8dc4a15211cbe3d0e4dfe58ae0bf47dbb29778c59928fe084eceb6')
+
+prepare() {
+ innoextract setup_quest_for_glory_vga_2.1.0.33.exe
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/gog"
+ cp -R "${srcdir}/app" "${pkgdir}/opt/gog/qfg1"
+ rm -rf "${pkgdir}/opt/gog/qfg1/DOSBOX"
+ cp -R "run-qfg1.conf" "${pkgdir}/opt/gog/qfg1"
+ cp -R "run-qfg1.sh" "${pkgdir}/opt/gog/qfg1"
+ # Config file that tells game to use SB instead of Roland MIDI for music
+ cp -R "RESOURCE.CFG" "${pkgdir}/opt/gog/qfg1"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp "gog-qfg1.desktop" "${pkgdir}/usr/share/applications"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/RESOURCE.CFG b/RESOURCE.CFG
new file mode 100644
index 000000000000..32505794c54f
--- /dev/null
+++ b/RESOURCE.CFG
@@ -0,0 +1,11 @@
+ videoDrv = VGA320.DRV
+ soundDrv = ADL.DRV 220
+ audioDrv = AUDBLAST.DRV 220
+ joyDrv = NO
+ kbdDrv = IBMKBD.DRV
+ mouseDrv = STDMOUSE.DRV
+ memoryDrv = ARM.DRV
+ minHunk = 200k
+ directory = \SIERRA\HERO
+ cmd = HERO
+ language = 1
diff --git a/gog-qfg1.desktop b/gog-qfg1.desktop
new file mode 100644
index 000000000000..02302b3354a3
--- /dev/null
+++ b/gog-qfg1.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=2.1.0.33
+Type=Application
+Name=Quest for Glory 1 (VGA)
+GenericName=Quest for Glory 1 (VGA)
+Comment=Quest for Glory 1 (VGA remake)
+Icon=/opt/gog/qfg1/goggame-1207661313.ico
+Exec=/opt/gog/qfg1/run-qfg1.sh
+Categories=Game;
+Path=/opt/gog/qfg1
diff --git a/run-qfg1.conf b/run-qfg1.conf
new file mode 100644
index 000000000000..73bbfc32ddf5
--- /dev/null
+++ b/run-qfg1.conf
@@ -0,0 +1,4 @@
+[autoexec]
+mount C .
+c:
+scidhuv.exe
diff --git a/run-qfg1.sh b/run-qfg1.sh
new file mode 100755
index 000000000000..9f1235bddb9a
--- /dev/null
+++ b/run-qfg1.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+set -e
+homedir="$HOME/.local/share/gog/qfg1"
+gogdir="/opt/gog/qfg1"
+rundir="$XDG_RUNTIME_DIR/gog/qfg1"
+mkdir -p "$homedir"
+mkdir -p "$rundir"
+/usr/bin/unionfs "$homedir=RW:$gogdir=RO" "$rundir"
+cd "$rundir"
+/usr/bin/dosbox -conf "$gogdir/dosboxQG1VGA.conf" -conf "$gogdir/run-qfg1.conf"
+cd "$gogdir"
+/usr/bin/fusermount -u "$rundir"