summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-06-11 20:19:06 +0200
committerAndré Fettouhi2015-06-11 20:19:06 +0200
commita04cd3a49073ab8f8438087f0359526963386d3f (patch)
tree5347de6332397d8a028e565cd9108c2f7a7fe808
downloadaur-a04cd3a49073ab8f8438087f0359526963386d3f.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--gog-rise-of-the-triad-dark-war36
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4df74a1aa1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-rise-of-the-triad-dark-war
+ pkgdesc = Old-school first person shooter with an arcade feel.
+ pkgver = 1.0.0.7
+ pkgrel = 1
+ url = http://www.gog.com/game/rise_of_the_triad__dark_war
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = libpng12
+ depends = unionfs-fuse
+ source = local://gog_rise_of_the_triad_dark_war_1.0.0.7.tar.gz
+ source = gog-rise-of-the-triad-dark-war
+ sha256sums = 100753a91fd212f367620c49fb26c36e382e96677ec504245a050235c7f22e6e
+ sha256sums = d74bb4ed35d23c4a788fca6cf14d4eb21a0a39e7e25cbc6d943fe1658bd7c343
+
+pkgname = gog-rise-of-the-triad-dark-war
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca9c41943c01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+
+pkgname=gog-rise-of-the-triad-dark-war
+pkgver=1.0.0.7
+pkgrel=1
+pkgdesc="Old-school first person shooter with an arcade feel."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/rise_of_the_triad__dark_war"
+license=("custom")
+groups=("games")
+source=("local://gog_rise_of_the_triad_dark_war_${pkgver}.tar.gz" "gog-rise-of-the-triad-dark-war")
+sha256sums=('100753a91fd212f367620c49fb26c36e382e96677ec504245a050235c7f22e6e'
+ 'd74bb4ed35d23c4a788fca6cf14d4eb21a0a39e7e25cbc6d943fe1658bd7c343')
+depends=(libpng12 unionfs-fuse)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/rise-of-the-triad-dark-war
+ cp -r "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/* "${pkgdir}"/opt/gog/rise-of-the-triad-dark-war
+ install -Dm644 "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/support/gog-rise-of-the-triad-dark-war-primary.desktop "${pkgdir}"/usr/share/applications/gog-rise-of-the-triad-dark-war.desktop
+ install -Dm644 "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/support/gog-rise-of-the-triad-dark-war-1.desktop "${pkgdir}"/usr/share/applications/gog-rise-of-the-triad-dark-war-server.desktop
+ install -Dm644 "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/support/gog-rise-of-the-triad-dark-war-2.desktop "${pkgdir}"/usr/share/applications/gog-rise-of-the-triad-dark-war-client.desktop
+ install -Dm644 "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/support/gog-rise-of-the-triad-dark-war.png "${pkgdir}"/usr/share/pixmaps/gog-rise-of-the-triad-dark-war.png
+ install -Dm644 "${srcdir}"/Rise\ of\ the\ Triad\ Dark\ War/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-rise-of-the-triad-dark-war" "${pkgdir}/usr/bin/gog-rise-of-the-triad-dark-war"
+}
+
diff --git a/gog-rise-of-the-triad-dark-war b/gog-rise-of-the-triad-dark-war
new file mode 100644
index 000000000000..d191c6e3be54
--- /dev/null
+++ b/gog-rise-of-the-triad-dark-war
@@ -0,0 +1,36 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/rise-of-the-triad-dark-war"
+homedir="$HOME/.gog/rise-of-the-triad-dark-war"
+mkdir -p "$homedir"/{game,config/data}
+
+if [[ ! -e "$homedir/config/dosboxRiseOTT.conf" ]]; then
+ cp "$gogdir/dosboxRiseOTT.conf" "$homedir/config/dosboxRiseOTT.conf"
+fi
+
+if [[ ! -e "$homedir/config/data/DARKWAR.WAD" ]]; then
+ cp "$gogdir/data/DARKWAR.WAD" "$homedir/config/data/DARKWAR.WAD"
+fi
+
+if [[ ! -e "$homedir/config/data/REMOTE1.RTS" ]]; then
+ cp "$gogdir/data/REMOTE1.RTS" "$homedir/config/data/REMOTE1.RTS"
+fi
+
+if [[ ! -e "$homedir/config/data/SOUND.ROT" ]]; then
+ cp "$gogdir/data/SOUND.ROT" "$homedir/config/data/SOUND.ROT"
+fi
+
+if [[ ! -e "$homedir/config/data/SCORES.ROT" ]]; then
+ cp "$gogdir/data/SCORES.ROT" "$homedir/config/data/SCORES.ROT"
+fi
+
+if [[ ! -e "$homedir/config/data/BATTLE.ROT" ]]; then
+ cp "$gogdir/data/BATTLE.ROT" "$homedir/config/data/BATTLE.ROT"
+fi
+
+if [[ ! -e "$homedir/config/data/CONFIG.ROT" ]]; then
+ cp "$gogdir/data/CONFIG.ROT" "$homedir/config/data/CONFIG.ROT"
+fi
+
+unionfs "$homedir/config=RW:$gogdir=RO" "$homedir/game"
+"$homedir"/game/start.sh
+fusermount -u "$homedir/game"