summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpostblue2016-11-12 11:40:47 +0100
committerpostblue2016-11-12 11:40:47 +0100
commit7dd0831d96f778f1b4a86671554f695032383842 (patch)
tree7d050e64ce8db678839997f1ec8b16d80843e777
downloadaur-7dd0831d96f778f1b4a86671554f695032383842.tar.gz
Initial commit with a libcurl problem
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD52
-rw-r--r--gog-risk-of-rain.desktop10
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6295c755716
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Nov 12 10:40:29 UTC 2016
+pkgbase = gog-risk-of-rain
+ pkgver = 2.1.0.5
+ pkgrel = 1
+ url = https://www.gog.com/game/risk_of_rain
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = gog://gog_risk_of_rain_2.1.0.5.sh
+ source = gog-risk-of-rain.desktop
+ sha256sums = 90d4a692928802602264a6e1690ee1fb2dc43e9c07329cb08cd57d06b06b9562
+ sha256sums = a1f0cc949d89cf5c9601b691989a5e728224f17b1f8c7d03d4c7f82be0a105ca
+ depends_i686 = alsa-lib
+ depends_i686 = libstdc++5
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-libstdc++5
+
+pkgname = gog-risk-of-rain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2fe10afc01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guillaume Hayot <postblue@postblue.info>
+
+pkgname=gog-risk-of-rain
+pkgver=2.1.0.5
+pkgrel=1
+pkgdsc="Risk of Rain is an action platformer with roguelike elements."
+url="https://www.gog.com/game/risk_of_rain"
+license=('custom')
+arch=('i686' 'x86_64')
+depends_x86_64=('lib32-alsa-lib' 'lib32-libstdc++5')
+depends_i686=('alsa-lib' 'libstdc++5')
+
+source=("gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop")
+sha256sums=('90d4a692928802602264a6e1690ee1fb2dc43e9c07329cb08cd57d06b06b9562'
+ 'a1f0cc949d89cf5c9601b691989a5e728224f17b1f8c7d03d4c7f82be0a105ca')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+# Prevent compressing final package
+PKGEXT='.pkg.tar'
+
+prepare(){
+ cd "$srcdir/data/noarch"
+ # The launcher expects the user to be in the game dir
+ echo -e "#!/bin/sh\ncd /opt/${pkgname}\n./start.sh" > "${srcdir}/${pkgname}"
+}
+
+package(){
+ cd "$srcdir"
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+ # using straight cp on the supplied tarball tends to have screwy permissions
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ install -Dm755 "data/noarch/start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gog-risk-of-rain.desktop b/gog-risk-of-rain.desktop
new file mode 100644
index 000000000000..33cc81a8a705
--- /dev/null
+++ b/gog-risk-of-rain.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Risk of Rain
+Comment=Risk of Rain is an action platformer with roguelike elements.
+Exec=gog-risk-of-rain
+Icon=gog-risk-of-rain
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8