summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNascher2015-09-18 15:40:15 +0000
committerNascher2015-09-18 15:50:12 +0000
commit856bfd566fcdb7f83190b53db06c18542f77ed7f (patch)
treef527af648306109b2135ffd263d882e82b1e02ed
parentee0f33384a38ece3c451dc9ca7c39290b14151a6 (diff)
downloadaur-856bfd566fcdb7f83190b53db06c18542f77ed7f.tar.gz
Update the package to 2.4.0.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD51
2 files changed, 22 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0feca7e58c6..3d01ea7d1615 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gog-shovel-knight
pkgdesc = Yacht Club Games
- pkgver = 2.3.0.5
+ pkgver = 2.4.0.6
pkgrel = 1
url = http://www.gog.com/game/shovel_knight
arch = i686
@@ -8,9 +8,9 @@ pkgbase = gog-shovel-knight
groups = games
license = custom:commercial
depends = sdl2
- source = gog://gog_shovel_knight_2.3.0.5.sh
+ source = gog://gog_shovel_knight_2.4.0.6.sh
source = gog-shovel-knight.desktop
- sha512sums = 7c4d8329acd2ee8fe05551e34a9d2de5181b03c08480871938741f8b53b876ab58bf5261d75817a3931f49f695a5aa7a75e2bf1e946fb923636566c333a6e679
+ sha512sums = 9532f25c4f599dbbd21609c496b86831e1f78cf1ba6847482ebba396e4b073f7477e57e0c94bad92661999af3fc49bf1950b0e9687946a716fdfbd80cb145bf4
sha512sums = a30a86d218c1249aef5e4f8116d90b61913c74a0bb0629ef1a04c3736d2a3d1960d6b28d562aa83bbc49383594c55de346f9e1893e222e50bba6ebe0d8cd43fc
pkgname = gog-shovel-knight
diff --git a/PKGBUILD b/PKGBUILD
index b31fb24d0144..c7e7d26ce0e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Nascher <kevin at nascher dot org>
# Contributor: Ludovic LE ROUX <bojurama12@yahoo.com>
-# This package is based on the gog-terraria package from Ainola.
+# This package is based on the gog-terraria package and the gog-freedom-planet package from Ainola.
pkgname=gog-shovel-knight
-pkgver=2.3.0.5
+pkgver=2.4.0.6
pkgrel=1
-pkgdesc="Yacht Club Games"
+pkgdesc='Yacht Club Games'
arch=("i686" "x86_64")
-url="http://www.gog.com/game/shovel_knight"
+url='http://www.gog.com/game/shovel_knight'
license=('custom:commercial')
depends=('sdl2')
-groups=("games")
-source=("gog://${pkgname//-/_}_${pkgver}.sh" "${pkgname}.desktop")
-sha512sums=('7c4d8329acd2ee8fe05551e34a9d2de5181b03c08480871938741f8b53b876ab58bf5261d75817a3931f49f695a5aa7a75e2bf1e946fb923636566c333a6e679'
+groups=('games')
+source=("${pkgname//-/_}_${pkgver}.sh" "${pkgname}.desktop")
+sha512sums=('9532f25c4f599dbbd21609c496b86831e1f78cf1ba6847482ebba396e4b073f7477e57e0c94bad92661999af3fc49bf1950b0e9687946a716fdfbd80cb145bf4'
'a30a86d218c1249aef5e4f8116d90b61913c74a0bb0629ef1a04c3736d2a3d1960d6b28d562aa83bbc49383594c55de346f9e1893e222e50bba6ebe0d8cd43fc')
# You need to download the gog.com installer file manually or with lgogdownloader.
@@ -23,44 +23,31 @@ DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to downl
PKGEXT='.pkg.tar'
prepare(){
- # Unzip will produce an error code because it is unable to unzip the Installer.
- # Therefore, a conditional into a no-op command will keep the PKGBUILD from failing
- # Of course, if you have any real problems unzipping the PKGBUILD will not abort.
- unzip -d "${srcdir}/shovel-knight" "${pkgname//-/_}_${pkgver}.sh" || :
- cd "${srcdir}/shovel-knight/data/noarch"
-
- # We must `cd` to the install dir before launching since the /usr/bin/
- # launcher is merely a link. It expects a certain folder structure.
-# sed -r -i \
-# 's/(declare -r CURRENT_DIR="\$\( cd "\$\( dirname )'`
-# `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
-# `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
-# "start.sh"
- sed -r -i \
- 's/(CURRENT_DIR="\$\( cd "\$\( dirname )'`
- `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
- `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
- "start.sh"
+ cd "$srcdir/data/noarch"
+ [ $CARCH == "x86" ] && rm -r "game/64"
+ [ $CARCH == "x86_64" ] && rm -r "game/32"
+ # The launcher expects the user to be in the game dir
+ echo -e "#!/bin/sh\ncd /opt/${pkgname}\n./start.sh" > "${srcdir}/${pkgname}"
}
package() {
- cd "${srcdir}/shovel-knight/data/noarch"
+ cd "$srcdir"
# Install game
install -d "${pkgdir}/opt/${pkgname}/"
install -d "${pkgdir}/opt/${pkgname}/support"
install -d "${pkgdir}/usr/bin/"
- cp -r "game/" "${pkgdir}/opt/${pkgname}/"
- install -Dm755 "start.sh" \
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 "data/noarch/start.sh" \
"${pkgdir}/opt/${pkgname}/"
- install -Dm755 support/*.{sh,shlib} -t \
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
"${pkgdir}/opt/${pkgname}/support"
# Desktop integration
- install -Dm 644 "support/icon.png" \
+ install -Dm 644 "data/noarch/support/icon.png" \
"${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "docs/End User License Agreement.txt" \
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
- ln -s "/opt/${pkgname}/start.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}