summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-06-10 19:57:54 +0200
committerAndré Fettouhi2015-06-10 19:57:54 +0200
commit75408ac563892243d0c0e4692fac82528fa7c253 (patch)
treeebe82a1dc5e538405c6bdb87c948d71ce7ec7532
downloadaur-75408ac563892243d0c0e4692fac82528fa7c253.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--gog-silent-service-112
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bc7792113e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gog-silent-service-1
+ pkgdesc = Prepare to dive into Silent Service, the submarine simulation that recreates authentic World War II sea patrols in the bloody waters of the South Pacific.
+ pkgver = 1.0.0.6
+ pkgrel = 1
+ url = http://www.gog.com/game/silent_service_12
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libpng12
+ depends = unionfs-fuse
+ source = local://gog_silent_service_1_1.0.0.6.tar.gz
+ source = gog-silent-service-1
+ sha256sums = ec42a0c160de7851d9da835a71cf43406459b4650785d44ef9b52a8e529b33f8
+ sha256sums = 6da31c2ed99247ae32d5fac2ccf664ade82660d4546a39df2d8f71ca4c38a496
+
+pkgname = gog-silent-service-1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a94a938a20b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+
+pkgname=gog-silent-service-1
+pkgver=1.0.0.6
+pkgrel=1
+pkgdesc="Prepare to dive into Silent Service, the submarine simulation that recreates authentic World War II sea patrols in the bloody waters of the South Pacific."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/silent_service_12"
+license=("custom")
+source=("local://gog_silent_service_1_${pkgver}.tar.gz"
+ "gog-silent-service-1")
+sha256sums=('ec42a0c160de7851d9da835a71cf43406459b4650785d44ef9b52a8e529b33f8'
+ '6da31c2ed99247ae32d5fac2ccf664ade82660d4546a39df2d8f71ca4c38a496')
+depends=(libpng12 unionfs-fuse)
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/silent-service-1
+ cp -r "${srcdir}"/Silent\ Service\ 1/* "${pkgdir}"/opt/gog/silent-service-1
+ install -Dm644 "${srcdir}"/Silent\ Service\ 1/support/gog-silent-service-1-primary.desktop "${pkgdir}"/usr/share/applications/gog-silent-service-1.desktop
+ install -Dm644 "${srcdir}"/Silent\ Service\ 1/support/gog-silent-service-1.png "${pkgdir}"/usr/share/pixmaps/gog-silent-service-1.png
+ install -Dm644 "${srcdir}"/Silent\ Service\ 1/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-silent-service-1" "${pkgdir}/usr/bin/gog-silent-service-1"
+}
+
+PKGEXT=.pkg.tar
diff --git a/gog-silent-service-1 b/gog-silent-service-1
new file mode 100644
index 000000000000..5a06356365bc
--- /dev/null
+++ b/gog-silent-service-1
@@ -0,0 +1,12 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/silent-service-1"
+homedir="$HOME/.gog/silent-service-1"
+mkdir -p "$homedir"/{game,config/data}
+
+if [[ ! -e "$homedir/config/dosboxSilentService.conf" ]]; then
+ cp "$gogdir/dosboxSilentService.conf" "$homedir/config/dosboxSilentService.conf"
+fi
+
+unionfs "$homedir/config=RW:$gogdir=RO" "$homedir/game"
+"$homedir"/game/start.sh
+fusermount -u "$homedir/game"