summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2017-01-11 21:34:18 -0700
committerAinola2017-01-11 21:34:18 -0700
commit474cc36c3385cefcf9fac34be1ecd2a4e50e8e3d (patch)
treea0b7ac9cffa6ba93a014ae6d7fe366045161a1a4
parent46fc956ef8f7910590de68142f506916e92fb7b4 (diff)
downloadaur-474cc36c3385cefcf9fac34be1ecd2a4e50e8e3d.tar.gz
remove sed function, just cd now that we have launcher
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--gog-terraria5
3 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ffad7eb6f0f..6a214bb24d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jan 12 04:21:43 UTC 2017
+# Thu Jan 12 04:28:48 UTC 2017
pkgbase = gog-terraria
pkgdesc = The very world is at your fingertips as you fight for survival, fortune, and glory.
pkgver = 2.13.0.16
@@ -15,7 +15,7 @@ pkgbase = gog-terraria
source = gog-terraria
sha256sums = 0ef29ce47158ecc55e680a7dc99458b599eabd45c99200437b19f2647b254c37
sha256sums = 815bf359c2828cdefee1e33a978a84a2ebb538450197a5792b62e382ae3e3093
- sha256sums = ac635a42cd64aa013e2f13b375ae10c1da7fd028681134962e10349f80725995
+ sha256sums = 9a5006f514457de51c65aab21fb4be12fb2c1df973b231f1c73db71cc6315795
pkgname = gog-terraria
diff --git a/PKGBUILD b/PKGBUILD
index 19e80521222b..b93b591a24ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ license=('custom')
arch=('i686' 'x86_64')
depends=('sdl2')
# If Firejail is installed, this application will be sandboxed automatically.
-optdepends=('firejail: Sandbox this game from your OS')
+optdepends=('firejail: Automatically sandbox this application from your OS')
source=("gog://${pkgname//-/_}_${pkgver}.sh"
"${pkgname}.desktop"
"$pkgname")
sha256sums=('0ef29ce47158ecc55e680a7dc99458b599eabd45c99200437b19f2647b254c37'
'815bf359c2828cdefee1e33a978a84a2ebb538450197a5792b62e382ae3e3093'
- 'ac635a42cd64aa013e2f13b375ae10c1da7fd028681134962e10349f80725995')
+ '939f39e8b8cbb30ae95648d299008df030b6c6e8e583893da1916e024b493e5b')
# You need to download the gog.com installer file manually or with lgogdownloader.
DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
@@ -28,13 +28,6 @@ prepare(){
# Therefore, a conditional into a no-op command will keep the PKGBUILD from failing
# Of course, if you have any real problems unzipping the PKGBUILD will not abort.
unzip -d "${srcdir}/terraria" "${pkgname//-/_}_${pkgver}.sh" || :
- cd "${srcdir}/terraria/data/noarch"
-
- sed -r -i \
- 's/(CURRENT_DIR="\$\( cd "\$\( dirname )'`
- `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
- `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
- "start.sh"
}
package(){
diff --git a/gog-terraria b/gog-terraria
index c5da0a0f6055..997586493372 100644
--- a/gog-terraria
+++ b/gog-terraria
@@ -1,10 +1,11 @@
#!/bin/sh
run='/opt/gog-terraria/start.sh'
+cd /opt/gog-terraria/ # The launcher fails unless in its dir.
if which firejail >/dev/null 2>&1 && [ -z "$FIREJAIL_IGNORE" ]; then
- echo "Firejail detected. Running with --caps.drop=all"
- echo "To bypass Firejail enforcement, run FIREJAIL_IGNORE=1 <program>."
+ echo "Firejail detected. Enforcing a sandbox"
+ echo "To bypass Firejail enforcement, run FIREJAIL_IGNORE=1 $run."
firejail --caps.drop=all "$run"
else
"$run"