summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorruniq2017-03-04 15:53:45 +0100
committerruniq2017-03-04 15:53:45 +0100
commitc416a01790d456c2ecd839e9317c790af303c8cb (patch)
tree9b7c43d970b3b662758aef357bdb5b4b5b47561c
downloadaur-c416a01790d456c2ecd839e9317c790af303c8cb.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--gog-torment-tides-of-numenera4
-rw-r--r--gog-torment-tides-of-numenera.desktop12
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a097df7176b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-torment-tides-of-numenera
+ pkgdesc = An RPG and the spiritual successor to Planescape: Torment
+ pkgver = 2.0.0.1
+ pkgrel = 1
+ url = https://torment.inxile-entertainment.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl2
+ source = gog://gog_torment_tides_of_numenera_2.0.0.1.sh
+ source = gog-torment-tides-of-numenera
+ source = gog-torment-tides-of-numenera.desktop
+ sha256sums = 2842af82dc6e7885fb4b104b1e13c4df1ffe5f21ca21d60a6d07e3f8508ee015
+ sha256sums = daa3eef865d94af6ce116ff176074feae94c5b84fba0b60ec17186bd57dd3758
+ sha256sums = 72b4a6024869b2e83a1a9371b1219d9f54ffaaf7f9a097c784cfc351ed64333e
+
+pkgname = gog-torment-tides-of-numenera
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d283058dc2bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrice Peterson <runiq at archlinux dot us>
+pkgname=gog-torment-tides-of-numenera
+_pkgname=torment-tides-of-numenera
+pkgver=2.0.0.1
+pkgrel=1
+pkgdesc="An RPG and the spiritual successor to Planescape: Torment"
+arch=('i686' 'x86_64')
+url="https://torment.inxile-entertainment.com"
+license=('custom')
+depends=("sdl2")
+DLAGENTS+=("gog::/usr/bin/echo Could not find %u. Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT in /etc/makepkg.conf.")
+source=("gog://gog_torment_tides_of_numenera_$pkgver.sh"
+ "$pkgname"
+ "$pkgname.desktop")
+sha256sums=('2842af82dc6e7885fb4b104b1e13c4df1ffe5f21ca21d60a6d07e3f8508ee015'
+ 'daa3eef865d94af6ce116ff176074feae94c5b84fba0b60ec17186bd57dd3758'
+ '72b4a6024869b2e83a1a9371b1219d9f54ffaaf7f9a097c784cfc351ed64333e')
+PKGEXT=".pkg.tar"
+
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ cp -r data/noarch/* "$pkgdir/opt/$pkgname"
+ # Remove packaged libraries that result in the game not starting
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/hicolor/256x256/$pkgname.png"
+ install -Dm644 data/noarch/docs/End\ User\ License\ Agreement.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/gog-torment-tides-of-numenera b/gog-torment-tides-of-numenera
new file mode 100644
index 000000000000..aea1f78c7f90
--- /dev/null
+++ b/gog-torment-tides-of-numenera
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gogdir="/opt/gog-torment-tides-of-numenera"
+"${gogdir}/start.sh"
diff --git a/gog-torment-tides-of-numenera.desktop b/gog-torment-tides-of-numenera.desktop
new file mode 100644
index 000000000000..74019a0ad27d
--- /dev/null
+++ b/gog-torment-tides-of-numenera.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Torment: Tides of Numenera
+GenericName=Torment: Tides of Numenera
+Comment=An RPG and the spiritual successor to Planescape: Torment
+Icon=/opt/gog-torment-tides-of-numenera/support/icon.png
+Exec=/opt/gog-torment-tides-of-numenera/start.sh
+Categories=Game;
+Path=/opt/gog-torment-tides-of-numenera
+