summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182020-06-29 22:11:11 +0200
committerLukas18182020-06-29 22:11:11 +0200
commit16d9adbf3977b5358982f2e92eea207596310463 (patch)
treef99177f687896a941f8aa74d9893115a1a41c14e
downloadaur-16d9adbf3977b5358982f2e92eea207596310463.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rwxr-xr-xWe are the Dwarves.desktop8
-rw-r--r--start-we-are-the-dwarves.sh2
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23d09422b408
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gog-we-are-the-dwarves
+ pkgdesc = An action-based tactical adventure with active pause (extreme slowdown of time) placing you in control of three Dwarven astronauts.
+ pkgver = 2.2.0.4
+ pkgrel = 1
+ url = https://www.gog.com/game/we_are_the_dwarves
+ arch = x86_64
+ license = custom
+ source = gogdownloader://we_are_the_dwarves/en3installer4
+ source = We are the Dwarves.desktop
+ source = start-we-are-the-dwarves.sh
+ sha512sums = 5a6b5dffa1be9e24b7eae0932cd0f063189e9be746800d00bc880d3ad7ae51df15d268e978c36ac3a9c8e8c0f0cea25f15e480afddc064f22d42e38996cad01d
+ sha512sums = d537996628ba1f4c8b492101ad3d4f3353ebd6c5a3042d6376521a7d10ea180025468b10b60f2d43d65d4221cedbba2e2560d0d7aa1a708e28e86e647f156cdc
+ sha512sums = d8e69e2e4c0b62de8d42319be391073e63b7597bb748dc3fbe5188cb42a6a423f9adba0839509b7061cc7b1bda3c3e911304b9d3e38eb3f48545c8247075737f
+
+pkgname = gog-we-are-the-dwarves
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0939a3e3669c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=gog-we-are-the-dwarves
+pkgver=2.2.0.4
+_pkgtag=$pkgver
+pkgrel=1
+pkgdesc="An action-based tactical adventure with active pause (extreme slowdown of time) placing you in control of three Dwarven astronauts."
+arch=('x86_64')
+url="https://www.gog.com/game/we_are_the_dwarves"
+license=('custom')
+source=("gogdownloader://we_are_the_dwarves/en3installer4"
+ "We are the Dwarves.desktop"
+ "start-we-are-the-dwarves.sh")
+sha512sums=('5a6b5dffa1be9e24b7eae0932cd0f063189e9be746800d00bc880d3ad7ae51df15d268e978c36ac3a9c8e8c0f0cea25f15e480afddc064f22d42e38996cad01d'
+ 'd537996628ba1f4c8b492101ad3d4f3353ebd6c5a3042d6376521a7d10ea180025468b10b60f2d43d65d4221cedbba2e2560d0d7aa1a708e28e86e647f156cdc'
+ 'd8e69e2e4c0b62de8d42319be391073e63b7597bb748dc3fbe5188cb42a6a423f9adba0839509b7061cc7b1bda3c3e911304b9d3e38eb3f48545c8247075737f')
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/$pkgname"
+ cp -r "${srcdir}/data/noarch/game" -T "${pkgdir}/opt/$pkgname"
+ chmod -R 644 "${pkgdir}/opt/$pkgname/"
+ chmod 755 "${pkgdir}/opt/$pkgname/watd.x86_64"
+ find "${pkgdir}/opt/$pkgname" -type d -exec chmod 755 {} \;
+ install -Dm 755 "${srcdir}/start-we-are-the-dwarves.sh" "${pkgdir}/usr/bin/we-are-the-dwarves"
+ install -Dm 755 "${srcdir}/We are the Dwarves.desktop" "$pkgdir/usr/share/applications/We are the Dwarves.desktop"
+ install -Dm 644 "${srcdir}/data/noarch/support/icon.png" "${pkgdir}/usr/share/pixmaps/$pkgname.png"
+ install -Dm 644 "${srcdir}/data/noarch/docs/End User License Agreement.txt" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/We are the Dwarves.desktop b/We are the Dwarves.desktop
new file mode 100755
index 000000000000..92ed392762fa
--- /dev/null
+++ b/We are the Dwarves.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=We are the Dwarves
+Exec=we-are-the-dwarves
+Comment=An action-based tactical adventure with active pause (extreme slowdown of time) placing you in control of three Dwarven astronauts.
+Terminal=false
+Icon=/usr/share/pixmaps/gog-we-are-the-dwarves.png
+Type=Application
+Categories=Game;
diff --git a/start-we-are-the-dwarves.sh b/start-we-are-the-dwarves.sh
new file mode 100644
index 000000000000..b00ccd003943
--- /dev/null
+++ b/start-we-are-the-dwarves.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+/opt/gog-we-are-the-dwarves//watd.x86_64