summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-11-18 15:47:00 -0600
committerDan Beste2017-11-18 15:48:01 -0600
commit38586df737461112702482631bcc98df9260f11d (patch)
treebe4e27549d3461b5900db3334356f98ad323df3d
downloadaur-gog-west-of-loathing.tar.gz
Init
v1.0.3
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD65
-rw-r--r--gog-west-of-loathing24
-rw-r--r--gog-west-of-loathing.desktop10
5 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7508f4f5c13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-west-of-loathing
+ pkgdesc = Say howdy to West of Loathing -- a single-player slapstick comedy adventure role-playing game set in the wild west of the Kingdom of Loathing universe.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = http://westofloathing.com/
+ arch = x86_64
+ groups = games
+ groups = gog
+ license = custom
+ source = gog-west-of-loathing
+ source = gog-west-of-loathing.desktop
+ source = file://west_of_loathing_en_1_0_3_16426.sh
+ sha256sums = 8125c647c046682ffa7738e1218f67b8d67662f7057b27eccc1fc1a6fb94aca9
+ sha256sums = 8b94a2a0a277bb91522476d723a80c0e1a075b36e87b9a770cdea9f7bf9ea21e
+ sha256sums = 02965e6a96b46004060c20bf6a14c334c256dc4e178e9d1d4fad8f9db9fba213
+
+pkgname = gog-west-of-loathing
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf1d0094a123
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!gog-west-of-loathing
+!gog-west-of-loathing.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b0433b926f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+
+# Notes:
+# + gog:// DLAGENT:
+# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
+# automatically pull game files from GOG.
+# - https://github.com/Sude-/lgogdownloader
+
+pkgname='gog-west-of-loathing'
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='Say howdy to West of Loathing -- a single-player slapstick comedy adventure role-playing game set in the wild west of the Kingdom of Loathing universe.'
+url='http://westofloathing.com/'
+license=('custom')
+groups=('games' 'gog')
+arch=('x86_64')
+source=(
+ "${pkgname}"
+ "${pkgname}.desktop"
+ 'file://west_of_loathing_en_1_0_3_16426.sh'
+)
+sha256sums=(
+ '8125c647c046682ffa7738e1218f67b8d67662f7057b27eccc1fc1a6fb94aca9'
+ '8b94a2a0a277bb91522476d723a80c0e1a075b36e87b9a770cdea9f7bf9ea21e'
+ '02965e6a96b46004060c20bf6a14c334c256dc4e178e9d1d4fad8f9db9fba213'
+)
+
+prepare() {
+ find . -type d -exec chmod 755 {} \;
+}
+
+package() {
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support/"
+ install -d "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -d "${pkgdir}/usr/share/pixmaps/"
+
+ cp -r data/noarch/game "${pkgdir}/opt/${pkgname}/"
+
+ install -m 755 \
+ "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -m 644 \
+ data/noarch/gameinfo \
+ "${pkgdir}/opt/${pkgname}/"
+ install -m 755 \
+ data/noarch/start.sh \
+ "${pkgdir}/opt/${pkgname}/"
+ install -m 755 \
+ data/noarch/support/*.{sh,shlib} \
+ "${pkgdir}/opt/${pkgname}/support/"
+ install -m 644 \
+ 'data/noarch/docs/End User License Agreement.txt' \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 644 \
+ "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -m 644 \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/gog-west-of-loathing b/gog-west-of-loathing
new file mode 100644
index 000000000000..cfd25c42683d
--- /dev/null
+++ b/gog-west-of-loathing
@@ -0,0 +1,24 @@
+#! /bin/bash
+
+pkgname='gog-west-of-loathing'
+pkgdir="/opt/${pkgname}/"
+run="${pkgdir}/start.sh"
+
+if hash firejail; then
+ echo "Firejail detected; attempting to enforce a sandbox..."
+ if [[ -f "${XDG_CONFIG_HOME}/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in ${XDG_CONFIG_HOME}/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ elif [[ -f "/etc/firejail/${pkgname}.profile" ]]; then
+ echo "Firejail profile for ${pkgname} found in /etc/firejail/"
+ echo "Enforcing a sandbox!"
+ firejail "${run}"
+ else
+ echo "No Firejail profile detected!"
+ echo "Skipping Firejail sandbox..."
+ "${run}"
+ fi
+else
+ "${run}"
+fi
diff --git a/gog-west-of-loathing.desktop b/gog-west-of-loathing.desktop
new file mode 100644
index 000000000000..875c498a3975
--- /dev/null
+++ b/gog-west-of-loathing.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=West of Loathing
+Comment=Say howdy to West of Loathing -- a single-player slapstick comedy adventure role-playing game set in the wild west of the Kingdom of Loathing universe.
+Exec=gog-west-of-loathing
+Icon=gog-west-of-loathing
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8