summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-12 12:34:40 -0500
committerDan Beste2017-04-12 12:34:40 -0500
commit26892071f0c08115191c7cacc19b0a59b9f665c9 (patch)
tree6a23de7ee0a61af9d4d815e32eb98ec130046261
parent7af8c6ad1d5760f5290ca9d6b54a836ca7e6da36 (diff)
downloadaur-26892071f0c08115191c7cacc19b0a59b9f665c9.tar.gz
Add sha256sum + refactor prepare()
+ 7z does not complain when extracting a damaged archive
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5b629917b7b..d8386d0139c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Yooka-Laylee is an all-new open-world platformer from key creative tale
url="http://www.playtonicgames.com/games/yooka-laylee/"
license=('custom')
arch=('i686' 'x86_64')
-depends=('sdl2')
+depends=('sdl2' 'p7zip')
optdepends=('firejail: Automatically sandbox this application from your OS')
source=(
"gog://${pkgname//-/_}_${pkgver}.sh"
@@ -16,7 +16,7 @@ source=(
"${pkgname}"
)
sha256sums=(
- 'SKIP'
+ 'e4aebe80ef947a0d4761770f618224a8bd7ba70e032d995c0ef05b1fb51f4451'
'eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca'
'4e4c5428a1d929007fea2204b688a4dcd97a13c992b5f92a0c7866f11adc8adc'
)
@@ -24,6 +24,12 @@ DLAGENTS=(
"gog::/usr/bin/echo %u Download the GOG file to $PWD or set up a gog:// DLAGENT."
)
+prepare() {
+ cd "${srcdir}"
+
+ 7z x gog_yooka_laylee_2.0.0.1.sh -tzip -y
+}
+
package(){
cd "${srcdir}"