summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-24 12:22:38 -0500
committerDan Beste2017-04-24 12:22:38 -0500
commitb3265a318f1b1117cbb0ac584e4bfb75a9fdd6ce (patch)
tree9e942f602b91c04e91a505e0ad0d9ee74f90b021
parent53f6514b93c388ad0c6014a5d599347d9b5330c0 (diff)
downloadaur-b3265a318f1b1117cbb0ac584e4bfb75a9fdd6ce.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD12
-rw-r--r--gog-yooka-laylee.profile18
4 files changed, 33 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30e69e8419cc..aef2778bb1eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,15 +6,16 @@ pkgbase = gog-yooka-laylee
arch = i686
arch = x86_64
license = custom
- depends = sdl2
- depends = p7zip
+ makedepends = p7zip
optdepends = firejail: Automatically sandbox this application from your OS
- source = gog://gog_yooka_laylee_2.0.0.1.sh
- source = gog-yooka-laylee.desktop
source = gog-yooka-laylee
- sha256sums = e4aebe80ef947a0d4761770f618224a8bd7ba70e032d995c0ef05b1fb51f4451
- sha256sums = eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca
+ source = gog-yooka-laylee.desktop
+ source = gog-yooka-laylee.profile
+ source = gog://gog_yooka_laylee_2.0.0.1.sh
sha256sums = 4e4c5428a1d929007fea2204b688a4dcd97a13c992b5f92a0c7866f11adc8adc
+ sha256sums = eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca
+ sha256sums = 45d542985620e05d6e60f52e3e9b348870f79b328cc118ff9bd5769e9fed5585
+ sha256sums = e4aebe80ef947a0d4761770f618224a8bd7ba70e032d995c0ef05b1fb51f4451
pkgname = gog-yooka-laylee
diff --git a/.gitignore b/.gitignore
index 3745bb129131..5c796b56fd53 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,4 +7,4 @@
!.SRCINFO
!gog-yooka-laylee
!gog-yooka-laylee.desktop
-
+!gog-yooka-laylee.profile
diff --git a/PKGBUILD b/PKGBUILD
index d8386d0139c4..7ea3584e5164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,19 @@ pkgdesc="Yooka-Laylee is an all-new open-world platformer from key creative tale
url="http://www.playtonicgames.com/games/yooka-laylee/"
license=('custom')
arch=('i686' 'x86_64')
-depends=('sdl2' 'p7zip')
+makedepends=('p7zip')
optdepends=('firejail: Automatically sandbox this application from your OS')
source=(
- "gog://${pkgname//-/_}_${pkgver}.sh"
- "${pkgname}.desktop"
"${pkgname}"
+ "${pkgname}.desktop"
+ "${pkgname}.profile"
+ "gog://${pkgname//-/_}_${pkgver}.sh"
)
sha256sums=(
- 'e4aebe80ef947a0d4761770f618224a8bd7ba70e032d995c0ef05b1fb51f4451'
- 'eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca'
'4e4c5428a1d929007fea2204b688a4dcd97a13c992b5f92a0c7866f11adc8adc'
+ 'eab3d609d3146cb69b32e9b9c894164323c3eab45628a33e9d1e6e75cd9ebbca'
+ '45d542985620e05d6e60f52e3e9b348870f79b328cc118ff9bd5769e9fed5585'
+ 'e4aebe80ef947a0d4761770f618224a8bd7ba70e032d995c0ef05b1fb51f4451'
)
DLAGENTS=(
"gog::/usr/bin/echo %u Download the GOG file to $PWD or set up a gog:// DLAGENT."
diff --git a/gog-yooka-laylee.profile b/gog-yooka-laylee.profile
new file mode 100644
index 000000000000..30517bbae8d5
--- /dev/null
+++ b/gog-yooka-laylee.profile
@@ -0,0 +1,18 @@
+# Modified steam.profile
+
+# TODO:
+# Savedirs? (Update pcgamingwiki)
+# Fix controller support.
+
+#noblacklist ???
+include /etc/firejail/disable-common.inc
+include /etc/firejail/disable-programs.inc
+include /etc/firejail/disable-devel.inc
+include /etc/firejail/disable-passwdmgr.inc
+
+caps.drop all
+netfilter
+nonewprivs
+noroot
+protocol unix,inet,inet6,netlink
+seccomp