summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdrie2021-01-21 20:31:11 -0800
committerxdrie2021-01-21 20:31:11 -0800
commit1dfbfdf0766cabf4c933f79747bde05dd76c1fe8 (patch)
tree09df429f309f45afac650b7b9dd5f30d244d5f56
parent6eb2eaef34c132baf8fe6a4199d1794e43c1e1e5 (diff)
downloadaur-1dfbfdf0766cabf4c933f79747bde05dd76c1fe8.tar.gz
update to use C rewrite of gogextract
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e838af03d86..eac0f4ffb68b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gogextract-git
pkgdesc = Unpack GOG Linux installers
- pkgver = r2.6601b32
- pkgrel = 2
- url = https://github.com/Yepoleb/gogextract
+ pkgver = r93.71b23e0
+ pkgrel = 1
+ url = https://github.com/IroAlexis/gogextract
arch = any
license = MIT
makedepends = git
- depends = python
+ depends = libzip
provides = gogextract
- source = git+https://github.com/Yepoleb/gogextract.git
+ source = git+https://github.com/IroAlexis/gogextract.git
sha256sums = SKIP
pkgname = gogextract-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d982c9aff95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
index 8a3e9e793446..472aae8fda47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: xhyi <xhahaya@gmail.com>
_pkgname=gogextract
pkgname=${_pkgname}-git
-pkgver=r2.6601b32
-pkgrel=2
+pkgver=r93.71b23e0
+pkgrel=1
pkgdesc='Unpack GOG Linux installers'
arch=('any')
-url='https://github.com/Yepoleb/gogextract'
+url='https://github.com/IroAlexis/gogextract'
license=('MIT')
-depends=('python')
+depends=('libzip')
makedepends=('git')
provides=("${_pkgname}")
source=("git+${url}.git")
@@ -19,8 +19,14 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${_pkgname}"
+
+ make
+}
+
package() {
- install -Dm755 "${_pkgname}/${_pkgname}.py" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" "${_pkgname}/LICENSE"
}