summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Kasin2019-08-05 05:58:54 -0700
committerBailey Kasin2019-08-05 05:58:54 -0700
commit3cdba0bba9095752479a6e6f518f05331f6966ef (patch)
tree902d16487a5bb072bddb16ea2ebff2b8989a1e07
parent831491188220e625f5004bfbbc3d78e5dc6ef205 (diff)
downloadaur-3cdba0bba9095752479a6e6f518f05331f6966ef.tar.gz
Fix current.json creation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gogios.install7
3 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bfc415088eb..060bf0043a41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogios
pkgdesc = Checks to see if required services are still running on important machines.
- pkgver = 1.0.r2.g58b610b
+ pkgver = 1.2.r0.g4ebd7ed
pkgrel = 1
url = https://github.com/bkasin/gogios
install = gogios.install
diff --git a/PKGBUILD b/PKGBUILD
index 165c9623f4fb..2f2b7d5bc87b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
pkgname=gogios
-pkgver=1.0.r2.g58b610b
+pkgver=1.2.r0.g4ebd7ed
pkgrel=1
pkgdesc="Checks to see if required services are still running on important machines."
arch=('x86_64')
diff --git a/gogios.install b/gogios.install
index b65fc5040178..01075ea27efa 100644
--- a/gogios.install
+++ b/gogios.install
@@ -1,13 +1,18 @@
post_install() {
if [ ! -f /etc/gingertechengine/checks.json ]; then
echo "Making default check file"
- mv /etc/gingertechengine/example.json /etc/gingertechengine/checks.json
+ cp /etc/gingertechengine/example.json /etc/gingertechengine/checks.json
fi
if [ ! -f /etc/gingertechengine/gogios.toml ]; then
echo "Making default config"
cp /etc/gingertechengine/gogios.sample.toml /etc/gingertechengine/gogios.toml
fi
+
+ if [ ! -f /opt/gingertechengine/js/current.json ]; then
+ echo "Making current results file"
+ cp /etc/gingertechengine/checks.json /opt/gingertechengine/js/current.json
+ fi
if id "gogios" >/dev/null 2>&1; then
echo "gogios user already exists"