summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Kasin2019-03-02 07:55:45 -0800
committerBailey Kasin2019-03-02 07:55:45 -0800
commitd6028ece73fbd6aab56a0f0298c72065cd5bd517 (patch)
tree7167bc6a59c9a546b3585b2d93b982a56b2cf77e
downloadaur-d6028ece73fbd6aab56a0f0298c72065cd5bd517.tar.gz
First commit. Version 1.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--gogios-bin.install19
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab7152b144b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gogios-bin
+ pkgdesc = Checks to see if required services are still running on important machines.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://angrysysadmins.tech
+ install = gogios-bin.install
+ arch = x86_64
+ license = MIT
+ depends = dotnet-sdk
+ depends = dotnet-runtime
+ depends = dotnet-host
+ optdepends = nginx
+ noextract = gogios-1.0.deb
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/BKasin/Gogios/releases/download/v1.0/gogios-1.0.deb
+ sha256sums = 32137aa91a691189aa370560fb7e8214f03ae96328854bfba236870f1912e5fe
+
+pkgname = gogios-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a398163cdfc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
+
+pkgname=gogios-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Checks to see if required services are still running on important machines."
+arch=('x86_64')
+url="https://angrysysadmins.tech"
+license=('MIT')
+depends=(
+ 'dotnet-sdk'
+ 'dotnet-runtime'
+ 'dotnet-host'
+)
+optdepends=('nginx')
+source=("https://github.com/BKasin/Gogios/releases/download/v${pkgver}/gogios-${pkgver}.deb")
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+noextract=("gogios-${pkgver}.deb")
+sha256sums=('32137aa91a691189aa370560fb7e8214f03ae96328854bfba236870f1912e5fe')
+
+package() {
+ bsdtar -O -xf gogios-${pkgver}.deb data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+}
+
diff --git a/gogios-bin.install b/gogios-bin.install
new file mode 100644
index 000000000000..9aa0e2a89da8
--- /dev/null
+++ b/gogios-bin.install
@@ -0,0 +1,19 @@
+post_install() {
+ if [ ! -f /etc/gingertechengine/checks.json ]; then
+ echo "Making default check file"
+ mv /etc/gingertechengine/example.json /etc/gingertechengine/checks.json
+ fi
+
+ echo "Start gogios and gogios-web for the system to run."
+}
+
+post_upgrade() {
+ post_install()
+}
+
+pre_remove() {
+ systemctl stop gogios-web
+ systemctl stop gogios
+ systemctl disable gogios-web
+ systemctl disable gogios
+}