aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2015-11-12 22:09:16 +0100
committerThomas Fanninger2015-11-12 22:09:16 +0100
commit47df7aac6f5a154ce8eb8cd405957acc9da2584a (patch)
tree779bcf1ea251e6a751ca2b8f0ba9709ee1cf7ea4
parentf14a0e216a2c0c05a20687e1ff0d603bf78e93d7 (diff)
downloadaur-47df7aac6f5a154ce8eb8cd405957acc9da2584a.tar.gz
Version 0.7.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--app_new.ini2
-rw-r--r--app_old.ini2
-rw-r--r--gogs.changelog10
-rw-r--r--helper.sh4
6 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44420879026d..cd850e3465a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogs
pkgdesc = Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language.
- pkgver = 0.7.0
+ pkgver = 0.7.6
pkgrel = 1
epoch = 1
url = http://gogs.io/
@@ -30,10 +30,10 @@ pkgbase = gogs
source = gogs.service
source = app.ini.patch
source = helper.sh
- source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.7.0
+ source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.7.6
sha512sums = c7abbe4af438a8a1db44537a16dbd40b82d50c921d53002c083071c4cd16644769e9d5dabbccedc1bd4ba563324186da4b4378365e098cc45df76402a657be90
sha512sums = 7fe59ae091353438bd59d1b27fd40663e2f53c073eedd5f321ae2e2f657de7af5efd10f0ce316dab3ef9f300e82450da5f86f64592d75e9b150b7d08d59af04a
- sha512sums = e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
+ sha512sums = 5dde38b286b2a27624e4c2f5c87c7eb279c6c5fc71dad818762b7100a8d20d5b16c14695624107e21b361ab662b90e769717325ba5f276067aa1ead38ae44e47
sha512sums = SKIP
pkgname = gogs
diff --git a/PKGBUILD b/PKGBUILD
index 6c0a20e10254..ab106b6629b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gogs
_pkgname=${pkgname}
-pkgver=0.7.0
+pkgver=0.7.6
pkgrel=1
epoch=1
pkgdesc="Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language."
@@ -33,7 +33,7 @@ source=('gogs.service'
sha512sums=(c7abbe4af438a8a1db44537a16dbd40b82d50c921d53002c083071c4cd16644769e9d5dabbccedc1bd4ba563324186da4b4378365e098cc45df76402a657be90
7fe59ae091353438bd59d1b27fd40663e2f53c073eedd5f321ae2e2f657de7af5efd10f0ce316dab3ef9f300e82450da5f86f64592d75e9b150b7d08d59af04a
- e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
+ 5dde38b286b2a27624e4c2f5c87c7eb279c6c5fc71dad818762b7100a8d20d5b16c14695624107e21b361ab662b90e769717325ba5f276067aa1ead38ae44e47
'SKIP')
_goroot="/usr/lib/go"
@@ -70,8 +70,8 @@ prepare() {
msg2 "Check and download dependencies from .gopmfile"
get_gopm "$GOPATH/src/${_gourl}/.gopmfile" "$GOPATH/src"
-# msg2 "Download missing dependencies"
-# go_get github.com/shurcooL/sanitized_anchor_name "$GOPATH/src/github.com/shurcooL/sanitized_anchor_name"
+ msg2 "Download missing dependencies"
+ go_get golang.org/x/crypto "$GOPATH/src/golang.org/x/crypto"
# msg2 "Workaround dependencies"
# cd "$GOPATH/src/github.com/gogits/go-gogs-client/"
diff --git a/app_new.ini b/app_new.ini
index 5e15e5557754..4d7cb553180a 100644
--- a/app_new.ini
+++ b/app_new.ini
@@ -48,6 +48,8 @@ HTTP_ADDR =
HTTP_PORT = 3000
; Disable SSH feature when not available
DISABLE_SSH = false
+; Whether use builtin SSH server or not.
+START_SSH_SERVER = false
SSH_PORT = 22
; Disable CDN even in "prod" mode
OFFLINE_MODE = false
diff --git a/app_old.ini b/app_old.ini
index a7115789f40f..bbbd5fc1afe8 100644
--- a/app_old.ini
+++ b/app_old.ini
@@ -48,6 +48,8 @@ HTTP_ADDR =
HTTP_PORT = 3000
; Disable SSH feature when not available
DISABLE_SSH = false
+; Whether use builtin SSH server or not.
+START_SSH_SERVER = false
SSH_PORT = 22
; Disable CDN even in "prod" mode
OFFLINE_MODE = false
diff --git a/gogs.changelog b/gogs.changelog
index 0f539d40367a..d4911aa633cd 100644
--- a/gogs.changelog
+++ b/gogs.changelog
@@ -1,3 +1,13 @@
+2015-11-12
+
+ * V0.7.6
+ Bug fix: Images in subdirectory does not have correct relative links #1904
+ Bug fix: SSH operations do not handle mixed cases URL
+ Bug fix: Wrong redirection after deleting system notice with sub-path #1930
+ Improvement: Show current branch in commit overview #1572
+ Improvement: Allow tab to button in issue view page and use enter or space bar to trigger click #1824 #1917
+ Features: Able to start builtin SSH server by config option [server] START_SSH_SERVER = true
+
2015-11-08
* V0.7.0
diff --git a/helper.sh b/helper.sh
index b32164d31d6b..18425b5bb086 100644
--- a/helper.sh
+++ b/helper.sh
@@ -58,6 +58,10 @@ function get_golang {
then
echo $1 $2 $3
get_git "github.com/golang/text" $2
+ elif [[ $1 == "golang.org/x/crypto" ]]
+ then
+ echo $1 $2 $3
+ get_git "github.com/golang/crypto" $2
else
echo $1 $2 $3
fi