aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2015-12-13 08:53:19 +0100
committerThomas Fanninger2015-12-13 08:53:19 +0100
commit4ebc36383e03009b3c0f6b6f4fc27933f9fc3812 (patch)
treef06ee04f074251cfb50a0d1e29b1f169cb8da278
parent33c2c09637d947151800255ccbc3c9e5f1520b36 (diff)
downloadaur-4ebc36383e03009b3c0f6b6f4fc27933f9fc3812.tar.gz
Version 0.8.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--app.ini.patch12
-rw-r--r--app_new.ini15
-rw-r--r--app_old.ini15
5 files changed, 33 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3e1e1d97948..b5a579ae199c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogs
pkgdesc = Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language.
- pkgver = 0.7.33
+ pkgver = 0.8.0
pkgrel = 1
epoch = 1
url = http://gogs.io/
@@ -30,9 +30,9 @@ pkgbase = gogs
source = gogs.service.patch
source = app.ini.patch
source = helper.sh
- source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.7.33
+ source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.8.0
sha512sums = 834e95fe9bcfa291a573ad1fa43f41bbed844658a918ff4fcf53ab8a44a296206ee4003eab1d9a2785c9126be077022f4907846d2eb6c5d64050b5e81ce47f44
- sha512sums = d4f6518c644b76e4d1688cd5756c9eea7a89d0abad68a14638ccc6f0d1006c164c1ae3b3f89efd903def7398a3dabce7299100303808ad7a1937407a9eb13a39
+ sha512sums = e0538ece387a9dcc9c4f3d9194287ce3a3a31a8c64711f046c362c866f460bb1a33a71cf7e3a768a82f91bb7afe7edb2a3d0d0868faa0dba1b49f6c30e443adf
sha512sums = e45775adafeecad5deaf24a98cd85b25a8383cb0e89905b2927c13fe7f0ec9918a42071ce43eabc429d8a826db93bb75ffb1927dce9c431ed88b0b5c619fd60d
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e33afb4961a1..03f27d549257 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gogs
_pkgname=${pkgname}
-pkgver=0.7.33
+pkgver=0.8.0
pkgrel=1
epoch=1
pkgdesc="Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language."
@@ -32,7 +32,7 @@ source=('gogs.service.patch'
"$_pkgname::git+https://${_gourl}.git#tag=v${pkgver}")
sha512sums=(834e95fe9bcfa291a573ad1fa43f41bbed844658a918ff4fcf53ab8a44a296206ee4003eab1d9a2785c9126be077022f4907846d2eb6c5d64050b5e81ce47f44
- d4f6518c644b76e4d1688cd5756c9eea7a89d0abad68a14638ccc6f0d1006c164c1ae3b3f89efd903def7398a3dabce7299100303808ad7a1937407a9eb13a39
+ e0538ece387a9dcc9c4f3d9194287ce3a3a31a8c64711f046c362c866f460bb1a33a71cf7e3a768a82f91bb7afe7edb2a3d0d0868faa0dba1b49f6c30e443adf
e45775adafeecad5deaf24a98cd85b25a8383cb0e89905b2927c13fe7f0ec9918a42071ce43eabc429d8a826db93bb75ffb1927dce9c431ed88b0b5c619fd60d
'SKIP')
diff --git a/app.ini.patch b/app.ini.patch
index 876a7691b225..de2da333416c 100644
--- a/app.ini.patch
+++ b/app.ini.patch
@@ -6,27 +6,27 @@
< ROOT =
---
> ROOT = /srv/gogs/repo
-69c69
+75c75
< STATIC_ROOT_PATH =
---
> STATIC_ROOT_PATH = /usr/share/themes/gogs/default
-85c85
+91c91
< PATH = data/gogs.db
---
> PATH = /srv/gogs/sqlite/gogs.db
-186c186
+192c192
< PROVIDER_CONFIG = data/sessions
---
> PROVIDER_CONFIG = /srv/gogs/sessions
-201c201
+207c207
< AVATAR_UPLOAD_PATH = data/avatars
---
> AVATAR_UPLOAD_PATH = /srv/gogs/data/avatars
-211c211
+217c217
< PATH = data/attachments
---
> PATH = /srv/gogs/data/attachments
-226c226
+232c232
< ROOT_PATH =
---
> ROOT_PATH = /var/log/gogs
diff --git a/app_new.ini b/app_new.ini
index f600eb3e6e1c..15d4cf57d7e2 100644
--- a/app_new.ini
+++ b/app_new.ini
@@ -15,6 +15,8 @@ SCRIPT_TYPE = bash
ANSI_CHARSET =
; Force every new repository to be private
FORCE_PRIVATE = false
+; Global maximum creation limit of repository per user, -1 means no limit
+MAX_CREATION_LIMIT = -1
; Patch test queue length, make it as large as possible
PULL_REQUEST_QUEUE_LENGTH = 10000
@@ -46,6 +48,10 @@ DOMAIN = localhost
ROOT_URL = %(PROTOCOL)s://%(DOMAIN)s:%(HTTP_PORT)s/
HTTP_ADDR =
HTTP_PORT = 3000
+; Local (DMZ) URL for Gogs workers (such as SSH update) accessing web service.
+; In most cases you do not need to change the default value.
+; Alter it only if your SSH server node is not the same as HTTP node.
+LOCAL_ROOT_URL = http://localhost:%(HTTP_PORT)s/
; Disable SSH feature when not available
DISABLE_SSH = false
; Whether use builtin SSH server or not.
@@ -265,8 +271,8 @@ ADDR =
; For "smtp" mode only
[log.smtp]
LEVEL =
-; Name displayed in mail title, default is "Diagnostic message from serve"
-SUBJECT = Diagnostic message from serve
+; Name displayed in mail title, default is "Diagnostic message from server"
+SUBJECT = Diagnostic message from server
; Mail server
HOST =
; Mailer user name and password
@@ -296,7 +302,8 @@ SCHEDULE = @every 1h
; Repository health check
[cron.repo_health_check]
SCHEDULE = @every 24h
-; Arguments for command 'git fsck', e.g.: "--unreachable --tags"
+TIMEOUT = 60s
+; Arguments for command 'git fsck', e.g. "--unreachable --tags"
; see more on http://git-scm.com/docs/git-fsck/1.7.5
ARGS =
@@ -307,7 +314,7 @@ SCHEDULE = @every 24h
[git]
MAX_GIT_DIFF_LINES = 10000
-; Arguments for command 'git gc', e.g.: "--aggressive --auto"
+; Arguments for command 'git gc', e.g. "--aggressive --auto"
; see more on http://git-scm.com/docs/git-gc/1.7.5
GC_ARGS =
diff --git a/app_old.ini b/app_old.ini
index 9e5cc286d76b..82ccdbd92405 100644
--- a/app_old.ini
+++ b/app_old.ini
@@ -15,6 +15,8 @@ SCRIPT_TYPE = bash
ANSI_CHARSET =
; Force every new repository to be private
FORCE_PRIVATE = false
+; Global maximum creation limit of repository per user, -1 means no limit
+MAX_CREATION_LIMIT = -1
; Patch test queue length, make it as large as possible
PULL_REQUEST_QUEUE_LENGTH = 10000
@@ -46,6 +48,10 @@ DOMAIN = localhost
ROOT_URL = %(PROTOCOL)s://%(DOMAIN)s:%(HTTP_PORT)s/
HTTP_ADDR =
HTTP_PORT = 3000
+; Local (DMZ) URL for Gogs workers (such as SSH update) accessing web service.
+; In most cases you do not need to change the default value.
+; Alter it only if your SSH server node is not the same as HTTP node.
+LOCAL_ROOT_URL = http://localhost:%(HTTP_PORT)s/
; Disable SSH feature when not available
DISABLE_SSH = false
; Whether use builtin SSH server or not.
@@ -265,8 +271,8 @@ ADDR =
; For "smtp" mode only
[log.smtp]
LEVEL =
-; Name displayed in mail title, default is "Diagnostic message from serve"
-SUBJECT = Diagnostic message from serve
+; Name displayed in mail title, default is "Diagnostic message from server"
+SUBJECT = Diagnostic message from server
; Mail server
HOST =
; Mailer user name and password
@@ -296,7 +302,8 @@ SCHEDULE = @every 1h
; Repository health check
[cron.repo_health_check]
SCHEDULE = @every 24h
-; Arguments for command 'git fsck', e.g.: "--unreachable --tags"
+TIMEOUT = 60s
+; Arguments for command 'git fsck', e.g. "--unreachable --tags"
; see more on http://git-scm.com/docs/git-fsck/1.7.5
ARGS =
@@ -307,7 +314,7 @@ SCHEDULE = @every 24h
[git]
MAX_GIT_DIFF_LINES = 10000
-; Arguments for command 'git gc', e.g.: "--aggressive --auto"
+; Arguments for command 'git gc', e.g. "--aggressive --auto"
; see more on http://git-scm.com/docs/git-gc/1.7.5
GC_ARGS =