aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2015-09-27 12:01:10 +0200
committerThomas Fanninger2015-09-27 12:01:10 +0200
commita88056875dd6c3085740a27278b385d861d7040d (patch)
tree928fbf97c10d8622b6c80617259b5179afa2140e
parentca291617be6e6a2c9060c946bd17291bf6a1e046 (diff)
downloadaur-a88056875dd6c3085740a27278b385d861d7040d.tar.gz
Release v0.6.15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--app.ini.patch12
-rw-r--r--app_new.ini66
-rw-r--r--app_old.ini66
-rw-r--r--gogs.changelog20
6 files changed, 80 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32bc68519599..0f47eb0b9212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogs
pkgdesc = Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language.
- pkgver = 0.6.9
+ pkgver = 0.6.15
pkgrel = 1
epoch = 1
url = http://gogs.io/
@@ -29,9 +29,9 @@ pkgbase = gogs
source = gogs.service
source = app.ini.patch
source = helper.sh
- source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.6.9
+ source = gogs::git+https://github.com/gogits/gogs.git#tag=v0.6.15
sha512sums = 2b4303f850e3b13b2fc3c9f0bc5820dae431d228002b35f01be0d4bfbcf05de8dcec2a559a85e318b609e4a4d492d44306eadf5f6508fd72333b198661bb0bb7
- sha512sums = 939be9ad851ae6e20b786e2e189b0b67c0198edfc8c83442934ec48c7be073e03c75172e79f23a6ee1e0eb467c6fa18096a66d69d1142ebba28fdc8bb2a3964c
+ sha512sums = cd00b1f29c0ab2eaf70647b51a7fe135aa00906dcda1b1d99c56ea3371fc6540f82bf77999018078b43294614317df253fb4217c2d84f873398c4a69ae2bfaa5
sha512sums = e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 30be755ff649..d222dcbc9b08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gogs
_pkgname=${pkgname}
-pkgver=0.6.9
+pkgver=0.6.15
pkgrel=1
epoch=1
pkgdesc="Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language."
@@ -31,7 +31,7 @@ source=('gogs.service'
"$_pkgname::git+https://${_gourl}.git#tag=v${pkgver}")
sha512sums=(2b4303f850e3b13b2fc3c9f0bc5820dae431d228002b35f01be0d4bfbcf05de8dcec2a559a85e318b609e4a4d492d44306eadf5f6508fd72333b198661bb0bb7
- 939be9ad851ae6e20b786e2e189b0b67c0198edfc8c83442934ec48c7be073e03c75172e79f23a6ee1e0eb467c6fa18096a66d69d1142ebba28fdc8bb2a3964c
+ cd00b1f29c0ab2eaf70647b51a7fe135aa00906dcda1b1d99c56ea3371fc6540f82bf77999018078b43294614317df253fb4217c2d84f873398c4a69ae2bfaa5
e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
'SKIP')
diff --git a/app.ini.patch b/app.ini.patch
index dd912fd9e8e1..1195bd336f3b 100644
--- a/app.ini.patch
+++ b/app.ini.patch
@@ -6,27 +6,27 @@
< ROOT =
---
> ROOT = /srv/gogs/repo
-43c43
+61c61
< STATIC_ROOT_PATH =
---
> STATIC_ROOT_PATH = /usr/share/themes/gogs/default
-59c59
+77c77
< PATH = data/gogs.db
---
> PATH = /srv/gogs/sqlite/gogs.db
-184c184
+168c168
< PROVIDER_CONFIG = data/sessions
---
> PROVIDER_CONFIG = /srv/gogs/sessions
-199c199
+183c183
< AVATAR_UPLOAD_PATH = data/avatars
---
> AVATAR_UPLOAD_PATH = /srv/gogs/data/avatars
-209c209
+193c193
< PATH = data/attachments
---
> PATH = /srv/gogs/data/attachments
-224c224
+208c208
< ROOT_PATH =
---
> ROOT_PATH = /var/log/gogs
diff --git a/app_new.ini b/app_new.ini
index 1a61538add51..c28ec844463c 100644
--- a/app_new.ini
+++ b/app_new.ini
@@ -13,8 +13,26 @@ ROOT = /srv/gogs/repo
SCRIPT_TYPE = bash
[ui]
+; Number of repositories that are showed in one explore page
+EXPLORE_PAGING_NUM = 20
; Number of issues that are showed in one page
ISSUE_PAGING_NUM = 10
+; Number of maximum commits showed in one activity feed
+FEED_MAX_COMMIT_NUM = 5
+
+[ui.admin]
+; Number of users that are showed in one page
+USER_PAGING_NUM = 50
+; Number of repos that are showed in one page
+REPO_PAGING_NUM = 50
+; Number of notices that are showed in one page
+NOTICE_PAGING_NUM = 50
+; Number of organization that are showed in one page
+ORG_PAGING_NUM = 50
+
+[markdown]
+; Enable hard line break extension
+ENABLE_HARD_LINE_BREAK = false
[server]
PROTOCOL = http
@@ -55,7 +73,7 @@ USER = root
PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
-; For "sqlite3" only
+; For "sqlite3" and "tidb"
PATH = /srv/gogs/sqlite/gogs.db
[admin]
@@ -89,6 +107,8 @@ ENABLE_REVERSE_PROXY_AUTHENTICATION = false
ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
; Do not check minimum key size with corresponding type
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
+; Enable captcha validation for registration
+ENABLE_CAPTCHA = true
[webhook]
; Hook task queue length
@@ -97,11 +117,13 @@ QUEUE_LENGTH = 1000
DELIVER_TIMEOUT = 5
; Allow insecure certification
SKIP_TLS_VERIFY = false
+; Number of history information in each page
+PAGING_NUM = 10
[mailer]
ENABLED = false
; Buffer length of channel, keep it as it is if you don't know what it is.
-SEND_BUFFER_LEN = 10
+SEND_BUFFER_LEN = 100
; Name displayed in mail title
SUBJECT = %(APP_NAME)s
; Mail server
@@ -125,44 +147,6 @@ FROM =
USER =
PASSWD =
-[oauth]
-ENABLED = false
-
-[oauth.github]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://api.github.com/user
-AUTH_URL = https://github.com/login/oauth/authorize
-TOKEN_URL = https://github.com/login/oauth/access_token
-
-; Get client id and secret from
-; https://console.developers.google.com/project
-[oauth.google]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile
-AUTH_URL = https://accounts.google.com/o/oauth2/auth
-TOKEN_URL = https://accounts.google.com/o/oauth2/token
-
-[oauth.qq]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = get_user_info
-; QQ 互联
-AUTH_URL = https://graph.qq.com/oauth2.0/authorize
-TOKEN_URL = https://graph.qq.com/oauth2.0/token
-
-[oauth.weibo]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = all
-AUTH_URL = https://api.weibo.com/oauth2/authorize
-TOKEN_URL = https://api.weibo.com/oauth2/access_token
-
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
ADAPTER = memory
@@ -210,7 +194,7 @@ PATH = /srv/gogs/data/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = image/jpeg|image/png
; Max size of each file. Defaults to 32MB
-MAX_SIZE = 32
+MAX_SIZE = 4
; Max number of files per upload. Defaults to 10
MAX_FILES = 5
diff --git a/app_old.ini b/app_old.ini
index 9b8e4145dc0b..615154193279 100644
--- a/app_old.ini
+++ b/app_old.ini
@@ -13,8 +13,26 @@ ROOT =
SCRIPT_TYPE = bash
[ui]
+; Number of repositories that are showed in one explore page
+EXPLORE_PAGING_NUM = 20
; Number of issues that are showed in one page
ISSUE_PAGING_NUM = 10
+; Number of maximum commits showed in one activity feed
+FEED_MAX_COMMIT_NUM = 5
+
+[ui.admin]
+; Number of users that are showed in one page
+USER_PAGING_NUM = 50
+; Number of repos that are showed in one page
+REPO_PAGING_NUM = 50
+; Number of notices that are showed in one page
+NOTICE_PAGING_NUM = 50
+; Number of organization that are showed in one page
+ORG_PAGING_NUM = 50
+
+[markdown]
+; Enable hard line break extension
+ENABLE_HARD_LINE_BREAK = false
[server]
PROTOCOL = http
@@ -55,7 +73,7 @@ USER = root
PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
-; For "sqlite3" only
+; For "sqlite3" and "tidb"
PATH = data/gogs.db
[admin]
@@ -89,6 +107,8 @@ ENABLE_REVERSE_PROXY_AUTHENTICATION = false
ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
; Do not check minimum key size with corresponding type
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
+; Enable captcha validation for registration
+ENABLE_CAPTCHA = true
[webhook]
; Hook task queue length
@@ -97,11 +117,13 @@ QUEUE_LENGTH = 1000
DELIVER_TIMEOUT = 5
; Allow insecure certification
SKIP_TLS_VERIFY = false
+; Number of history information in each page
+PAGING_NUM = 10
[mailer]
ENABLED = false
; Buffer length of channel, keep it as it is if you don't know what it is.
-SEND_BUFFER_LEN = 10
+SEND_BUFFER_LEN = 100
; Name displayed in mail title
SUBJECT = %(APP_NAME)s
; Mail server
@@ -125,44 +147,6 @@ FROM =
USER =
PASSWD =
-[oauth]
-ENABLED = false
-
-[oauth.github]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://api.github.com/user
-AUTH_URL = https://github.com/login/oauth/authorize
-TOKEN_URL = https://github.com/login/oauth/access_token
-
-; Get client id and secret from
-; https://console.developers.google.com/project
-[oauth.google]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile
-AUTH_URL = https://accounts.google.com/o/oauth2/auth
-TOKEN_URL = https://accounts.google.com/o/oauth2/token
-
-[oauth.qq]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = get_user_info
-; QQ 互联
-AUTH_URL = https://graph.qq.com/oauth2.0/authorize
-TOKEN_URL = https://graph.qq.com/oauth2.0/token
-
-[oauth.weibo]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = all
-AUTH_URL = https://api.weibo.com/oauth2/authorize
-TOKEN_URL = https://api.weibo.com/oauth2/access_token
-
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
ADAPTER = memory
@@ -210,7 +194,7 @@ PATH = data/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = image/jpeg|image/png
; Max size of each file. Defaults to 32MB
-MAX_SIZE = 32
+MAX_SIZE = 4
; Max number of files per upload. Defaults to 10
MAX_FILES = 5
diff --git a/gogs.changelog b/gogs.changelog
index 28205c82fe89..dc05fb63da99 100644
--- a/gogs.changelog
+++ b/gogs.changelog
@@ -1,6 +1,24 @@
+2015-09-26
+
+ * V0.6.15
+ Bug fix: 404 when Repository name contains "git" #1593
+ Bug fix: Collaborative repositories missing suburl on dashboard #1594
+ Bug fix: Duplicate commit references when push a new branch #1595
+ Bug fix: Upload image does not handle suburl #1603
+ Bug fix: New SSH keys with comments including whitespace are truncated #1622
+ Bug fix: Change label title resets color #1659
+ Improvement: Able to use GOGS_WORK_DIR environment variable to specify work directory
+ Improvement: Enable login type conversion after account creation #748
+ Improvement: Sort owners list by last changed time when create and migrate repositoriy #1585
+ Features: Add TiDB backend database support
+ Features: Add Emoji support #633
+ Features: Able to disable captcha by config option [service] ENABLE_CAPTCHA = false #697
+ Features: Able to restrict SMTP authentication to specific domains #1620
+ Others: Drop social account login support
+
2015-09-05
- * V0.6.9
+ * V0.6.9
Bug fix: File name with double quotation mark makes the repository inaccessible #966
Bug fix: Time zone trouble #1500
Bug fix: Removing deploy key does not remove key #1535