aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2015-08-12 17:45:44 +0200
committerThomas Fanninger2015-08-12 17:45:44 +0200
commitbacfb18b7342d6ac71a7900ca194c039ded7404b (patch)
tree41300d8139b7f3b148d15456796e055e071e043d
parent3b52448f1901a64d23c2cbc43b26cfee31bae55f (diff)
downloadaur-bacfb18b7342d6ac71a7900ca194c039ded7404b.tar.gz
Version 0.6.3
-rw-r--r--PKGBUILD2
-rw-r--r--app.ini.patch12
-rw-r--r--app_new.ini20
-rw-r--r--app_old.ini20
-rw-r--r--gogs.changelog24
5 files changed, 59 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93638103b77c..0cb47a850991 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gogs
_pkgname=${pkgname}
-pkgver=0.6.1
+pkgver=0.6.3
pkgrel=1
epoch=1
pkgdesc="Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language."
diff --git a/app.ini.patch b/app.ini.patch
index b664b45f4384..a93fb78a16f6 100644
--- a/app.ini.patch
+++ b/app.ini.patch
@@ -6,27 +6,27 @@
< ROOT =
---
> ROOT = /srv/gogs/repo
-39c39
+43c43
< STATIC_ROOT_PATH =
---
> STATIC_ROOT_PATH = /usr/share/themes/gogs/default
-55c55
+59c59
< PATH = data/gogs.db
---
> PATH = /srv/gogs/sqlite/gogs.db
-176c176
+184c184
< PROVIDER_CONFIG = data/sessions
---
> PROVIDER_CONFIG = /srv/gogs/sessions
-191c191
+199c199
< AVATAR_UPLOAD_PATH = data/avatars
---
> AVATAR_UPLOAD_PATH = /srv/gogs/data/avatars
-200c200
+208c208
< PATH = data/attachments
---
> PATH = /srv/gogs/data/attachments
-215c215
+223c223
< ROOT_PATH =
---
> ROOT_PATH = /var/log/gogs
diff --git a/app_new.ini b/app_new.ini
index feb894fb5533..61a3569cdf05 100644
--- a/app_new.ini
+++ b/app_new.ini
@@ -12,6 +12,10 @@ RUN_MODE = dev
ROOT = /srv/gogs/repo
SCRIPT_TYPE = bash
+[ui]
+; Number of issues that are showed in one page
+ISSUE_PAGING_NUM = 10
+
[server]
PROTOCOL = http
DOMAIN = localhost
@@ -87,8 +91,8 @@ ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
[webhook]
-; Cron task interval in minutes
-TASK_INTERVAL = 1
+; Hook task queue length
+QUEUE_LENGTH = 1000
; Deliver timeout in seconds
DELIVER_TIMEOUT = 5
; Allow insecure certification
@@ -104,14 +108,18 @@ SUBJECT = %(APP_NAME)s
; Gmail: smtp.gmail.com:587
; QQ: smtp.qq.com:25
; Note, if the port ends with "465", SMTPS will be used. Using STARTTLS on port 587 is recommended per RFC 6409. If the server supports STARTTLS it will always be used.
-HOST =
+HOST =
+; Disable HELO operation when hostname are different.
+DISABLE_HELO =
+; Custom hostname for HELO operation, default is from system.
+HELO_HOSTNAME =
; Do not verify the certificate of the server. Only use this for self-signed certificates
SKIP_VERIFY =
; Use client certificate
USE_CERTIFICATE = false
CERT_FILE = custom/mailer/cert.pem
KEY_FILE = custom/mailer/key.pem
-; Mail from address, RFC 5322. This can be just an email address, or the "Name" <email@example.com> format
+; Mail from address, RFC 5322. This can be just an email address, or the `"Name" <email@example.com>` format
FROM =
; Mailer user name and password
USER =
@@ -288,8 +296,8 @@ INTERVAL = 24
ARGS =
[i18n]
-LANGS = en-US,zh-CN,zh-HK,de-DE,fr-FR,nl-NL,lv-LV,ru-RU,ja-JP,es-ES,pt-BR,pl-PL
-NAMES = English,简体中文,繁體中文,Deutsch,Français,Nederlands,Latviešu,Русский,日本语,Español,Português,Polski
+LANGS = en-US,zh-CN,zh-HK,de-DE,fr-FR,nl-NL,lv-LV,ru-RU,ja-JP,es-ES,pt-BR,pl-PL,bg-BG,it-IT
+NAMES = English,简体中文,繁體中文,Deutsch,Français,Nederlands,Latviešu,Русский,日本语,Español,Português,Polski,български,Italiano
[other]
SHOW_FOOTER_BRANDING = false \ No newline at end of file
diff --git a/app_old.ini b/app_old.ini
index 6b7d33b23130..c5aeeb94e6e9 100644
--- a/app_old.ini
+++ b/app_old.ini
@@ -12,6 +12,10 @@ RUN_MODE = dev
ROOT =
SCRIPT_TYPE = bash
+[ui]
+; Number of issues that are showed in one page
+ISSUE_PAGING_NUM = 10
+
[server]
PROTOCOL = http
DOMAIN = localhost
@@ -87,8 +91,8 @@ ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
[webhook]
-; Cron task interval in minutes
-TASK_INTERVAL = 1
+; Hook task queue length
+QUEUE_LENGTH = 1000
; Deliver timeout in seconds
DELIVER_TIMEOUT = 5
; Allow insecure certification
@@ -104,14 +108,18 @@ SUBJECT = %(APP_NAME)s
; Gmail: smtp.gmail.com:587
; QQ: smtp.qq.com:25
; Note, if the port ends with "465", SMTPS will be used. Using STARTTLS on port 587 is recommended per RFC 6409. If the server supports STARTTLS it will always be used.
-HOST =
+HOST =
+; Disable HELO operation when hostname are different.
+DISABLE_HELO =
+; Custom hostname for HELO operation, default is from system.
+HELO_HOSTNAME =
; Do not verify the certificate of the server. Only use this for self-signed certificates
SKIP_VERIFY =
; Use client certificate
USE_CERTIFICATE = false
CERT_FILE = custom/mailer/cert.pem
KEY_FILE = custom/mailer/key.pem
-; Mail from address, RFC 5322. This can be just an email address, or the "Name" <email@example.com> format
+; Mail from address, RFC 5322. This can be just an email address, or the `"Name" <email@example.com>` format
FROM =
; Mailer user name and password
USER =
@@ -288,8 +296,8 @@ INTERVAL = 24
ARGS =
[i18n]
-LANGS = en-US,zh-CN,zh-HK,de-DE,fr-FR,nl-NL,lv-LV,ru-RU,ja-JP,es-ES,pt-BR,pl-PL
-NAMES = English,简体中文,繁體中文,Deutsch,Français,Nederlands,Latviešu,Русский,日本语,Español,Português,Polski
+LANGS = en-US,zh-CN,zh-HK,de-DE,fr-FR,nl-NL,lv-LV,ru-RU,ja-JP,es-ES,pt-BR,pl-PL,bg-BG,it-IT
+NAMES = English,简体中文,繁體中文,Deutsch,Français,Nederlands,Latviešu,Русский,日本语,Español,Português,Polski,български,Italiano
[other]
SHOW_FOOTER_BRANDING = false \ No newline at end of file
diff --git a/gogs.changelog b/gogs.changelog
index 257a44f8e84c..a93f0aa15003 100644
--- a/gogs.changelog
+++ b/gogs.changelog
@@ -1,3 +1,27 @@
+2015-08-02
+
+ * V0.6.2
+ Bug fix: Label disappeared after edited a label #542
+ Bug fix: Filename cut off in DIFF when containing spaces #985
+ Bug fix: Migrate repository requires HTTPS address #1000
+ Bug fix: Private repositories issues included in "Public Activity" #1112
+ Bug fix: All users email are public #1127
+ Bug fix: API calls are not hidden behind sign in #1128
+ Bug fix: 404 on files with url-encoded names #1137
+ Bug fix: It is possible to access user profiles using organization URL #1169
+ Bug fix: Didn't check blank user name on LDAP #1207
+ Bug fix: Generated certificate doesn't have CN with the hostname #1231
+ Bug fix: Removing user from organization collaboration removes repositiory #1279
+ Bug fix: Create repo for other users by hacking uid field #1289
+ Improvement: Clearer error message for illegal characters #1070
+ Improvement: Add full name field to admin's user edit page #1130
+ Improvement: Hide organization email for non logged-in users #1204
+ Improvement: Visit Repository home page with ".git" appended URL #1227
+ Feature: Support realtime webhook #835
+ Others: Add Italian language support.
+ Others: Disable Macaron color log in production mode to improve performance
+ Others: Show repository owner name in explore page #1150
+
2015-03-26
* V0.6.1