summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinas Valatka2018-12-12 21:20:07 +0200
committerEdvinas Valatka2018-12-12 21:20:07 +0200
commit9260d7837050f622bb28fa7136df97a0fa1f56ba (patch)
tree196c13f5e9617694e4564065ff013799a3100b80
parent324221942522e6799c4012f6498782d2292cd35f (diff)
downloadaur-9260d7837050f622bb28fa7136df97a0fa1f56ba.tar.gz
Some small fixes:
Fix build dir path Add aarch64 arch Fix gogs home in tmpfiles.d
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
-rw-r--r--gogs.install2
-rw-r--r--gogs.tmpfiles2
4 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e954582fbb8b..fd210c4d9361 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogs-git
pkgdesc = Self Hosted Git Service in the Go Programming Language. This is the current git version from branch master.
- pkgver = 0.11.53.0603+2+91441c3fb
+ pkgver = 0.11.79.1211+1+f43d21d0a
pkgrel = 1
url = https://gogs.io
install = gogs.install
@@ -8,6 +8,7 @@ pkgbase = gogs-git
arch = x86_64
arch = armv6h
arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
makedepends = go
@@ -28,14 +29,14 @@ pkgbase = gogs-git
options = !buildflags
options = !strip
options = emptydirs
- source = git+https://github.com/gogs/gogs.git#branch=master
+ source = gogs::git+https://github.com/gogs/gogs.git#branch=master
source = gogs.service
source = gogs.sysusers
source = gogs.tmpfiles
sha512sums = SKIP
sha512sums = 26fa3b9579ec2780e56f4a52870461b9cc1e4c1608e006b0759de7c5de137895d48e94a1694341b545be0dae87c966a982d8b581397d56fad83ab12e297f98df
sha512sums = 0a546902ffb9fe99f61b301183059cc85c75408cd735f04ee93829ad6e3d66a07ebc73ce663743f109ea6303c1815933a17fe2b83bf9104d1528acb5aa63faf8
- sha512sums = a48c51665079575aa9e4774e9d6ccaf15880c81d3d8d77dbcc0871133be7907177694986f12a5d880aa1930a636ca42b5ccb2dbb91874ad9f3c31fa6e5218c6b
+ sha512sums = ffd60cd6fa08786e6d53580a43597013753c16a0e7dec93b8ba9aef944f3225e74b032bf8a9819e0a60e1b5fb503b8378b5710d84d5dd52159b91641ee483876
pkgname = gogs-git
diff --git a/PKGBUILD b/PKGBUILD
index 37507173bdcd..3973c839e765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Contributor: Thomas Laroche <tho.laroche@gmail.com>
# Contributor: Thomas Fanninger <thomas@fanninger.at>
# Contributor: surefire@cryptomile.net
+# Contributor: Martchus <martchus@gmx.net>
# Maintainer: Edvinas Valatka <edacval@gmail.com>
_branch=master
_pkgname=gogs
_team=github.com/gogs
-_gogsdir="${_team}/${_pkgname}"
pkgname=${_pkgname}-git
-pkgver=0.11.53.0603+2+91441c3fb
+pkgver=0.11.79.1211+1+f43d21d0a
pkgrel=1
pkgdesc="Self Hosted Git Service in the Go Programming Language. This is the current git version from branch ${_branch}."
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://${_pkgname}.io"
license=('MIT')
depends=('git' 'pam')
@@ -27,19 +27,16 @@ conflicts=("${_pkgname}")
provides=("${_pkgname}")
options=('!buildflags' '!strip' 'emptydirs')
install=${_pkgname}.install
-
-source=("git+https://${_team}/${_pkgname}.git#branch=${_branch}"
+source=("${_pkgname}::git+https://${_team}/${_pkgname}.git#branch=${_branch}"
"${_pkgname}.service"
"${_pkgname}.sysusers"
"${_pkgname}.tmpfiles")
prepare() {
- export GOPATH="$srcdir"
+ mkdir -p "${srcdir}/src/${_team}"
+ mv -v "${srcdir}/${_pkgname}" "${srcdir}/src/${_team}/${_pkgname}"
- mkdir -p "$srcdir/${_team}"
- mv -v -t "$srcdir/${_team}" ./${_pkgname}
-
- cd "$srcdir/$_gogsdir"
+ cd "$srcdir/src/${_team}/${_pkgname}"
sed -E -i conf/app.ini \
-e '0, /^\[/ s/^(RUN_USER)\W.*$/\1 = gogs/' \
@@ -49,7 +46,7 @@ prepare() {
}
pkgver() {
- cd "$srcdir/$_gogsdir"
+ cd "$srcdir/src/${_team}/${_pkgname}"
printf '%s+%s+%s' \
$(sed -e 's,/,+,g; s, ,,g' templates/.VERSION) \
$(git rev-list --count HEAD...$(git log --pretty=format:%H -n 1 -- templates/.VERSION)) \
@@ -59,15 +56,14 @@ pkgver() {
build() {
export GOPATH="$srcdir"
-
- cd "$srcdir/$_gogsdir"
+ cd "$srcdir/src/${_team}/${_pkgname}"
go fix
LDFLAGS='-s -w' make PATH="$GOPATH/bin:$PATH" TAGS='libsqlite3 sqlite pam cert' build
}
package() {
- cd "$srcdir/$_gogsdir"
+ cd "$srcdir/src/${_team}/${_pkgname}"
rm -rf ./public/{less,config.codekit}
@@ -85,4 +81,4 @@ package() {
sha512sums=('SKIP'
'26fa3b9579ec2780e56f4a52870461b9cc1e4c1608e006b0759de7c5de137895d48e94a1694341b545be0dae87c966a982d8b581397d56fad83ab12e297f98df'
'0a546902ffb9fe99f61b301183059cc85c75408cd735f04ee93829ad6e3d66a07ebc73ce663743f109ea6303c1815933a17fe2b83bf9104d1528acb5aa63faf8'
- 'a48c51665079575aa9e4774e9d6ccaf15880c81d3d8d77dbcc0871133be7907177694986f12a5d880aa1930a636ca42b5ccb2dbb91874ad9f3c31fa6e5218c6b')
+ 'ffd60cd6fa08786e6d53580a43597013753c16a0e7dec93b8ba9aef944f3225e74b032bf8a9819e0a60e1b5fb503b8378b5710d84d5dd52159b91641ee483876')
diff --git a/gogs.install b/gogs.install
index eaa5aa5e62b5..1b66ba577e2e 100644
--- a/gogs.install
+++ b/gogs.install
@@ -57,7 +57,7 @@ post_upgrade() {
local _CustConf=${_gogs_home}/custom/conf/app.ini
if [ ! -f ${_CustConf} ] ; then
- echo " Gogs old configuration file must be moved to ${_CustConf} before starting service."
+ echo " Gogs old configuration file must be moved to ${_CustConf} before starting or re-enabling service."
_disable_if_enabled
fi
_start_if_enabled
diff --git a/gogs.tmpfiles b/gogs.tmpfiles
index fd7743fed86f..c1d4065a6de3 100644
--- a/gogs.tmpfiles
+++ b/gogs.tmpfiles
@@ -1,2 +1,2 @@
-d /var/lib/gogs 0700 gogs gogs -
+d /var/lib/gogs 0750 gogs gogs -
d /var/log/gogs 0750 gogs log -