summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVPeti12024-04-09 20:17:10 +0200
committerVPeti12024-04-09 20:17:10 +0200
commit69ff08babd871002c973071e024e32b2e07c7457 (patch)
tree4a0b9b940bc463b4a934707ec1ff09d3e1190e36
downloadaur-69ff08babd871002c973071e024e32b2e07c7457.tar.gz
Added PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86e45129ef45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gohash
+ pkgdesc = Calculate a files SHA256 sum with 1 command
+ pkgver = 1
+ pkgrel = 1
+ arch = x86_64
+ license = GPL3
+ depends = go
+ depends = git
+ depends = wget
+ source = https://github.com/VPeti1/CWAcces/raw/main/gohash.tar.gz
+ sha256sums = 00fdb7b019ce012167f49be9188611f13bcaa0d7304103fdd7816e30b4e5069b
+
+pkgname = gohash
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2820bb9c33d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: VPeti1 (Vasko Peter)
+
+pkgname=gohash
+pkgver=1
+pkgrel=1
+arch=('x86_64')
+
+license=('GPL3')
+pkgdesc="Calculate a files SHA256 sum with 1 command "
+
+depends=('go' 'git' 'wget')
+
+source=("https://github.com/VPeti1/CWAcces/raw/main/gohash.tar.gz")
+
+sha256sums=('00fdb7b019ce012167f49be9188611f13bcaa0d7304103fdd7816e30b4e5069b')
+
+build() {
+ cd "$srcdir"
+ go build main.go
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 main "$pkgdir/usr/bin/gohash"
+}
+
+