summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lima2015-10-13 12:14:49 -0300
committerDaniel Lima2015-10-13 12:14:49 -0300
commit72170b3be7b77bdee535995bacab6519a7a9bc5d (patch)
tree3be82323e617418f0735674f9de50ab977d4a1f2
downloadaur-72170b3be7b77bdee535995bacab6519a7a9bc5d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1569600fdd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gohufont-powerline
+ pkgdesc = GohuFont with powerline and statusbar symbols.
+ pkgver = 0.1.r1.g0b2a9cf
+ pkgrel = 1
+ url = https://github.com/dnmario/gohufont-powerline
+ arch = any
+ license = WTFPL
+ makedepends = xorg-bdftopcf
+ source = git://github.com/dnmario/gohufont-powerline
+ md5sums = SKIP
+
+pkgname = gohufont-powerline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..206e67f83320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Daniel Lima <danielm@tinyhub.tk>
+
+pkgname=gohufont-powerline
+_gitname=$pkgname
+pkgver=0.1.r1.g0b2a9cf
+pkgrel=1
+depends=()
+makedepends=('xorg-bdftopcf')
+url=('https://github.com/dnmario/gohufont-powerline')
+license='WTFPL'
+pkgdesc="GohuFont with powerline and statusbar symbols."
+arch=('any')
+source=("git://github.com/dnmario/${_gitname}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install DESTDIR=$pkgdir
+}
+