summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRishabh Dwivedi2020-04-22 05:26:31 +0530
committerRishabh Dwivedi2020-04-22 05:26:31 +0530
commitb91f80b51d6dc4dd3c46e58d1264a287ffb02682 (patch)
treede6971a9ef1774ada6880ce71eec606b82a696c2
downloadaur-b91f80b51d6dc4dd3c46e58d1264a287ffb02682.tar.gz
adding gohup to aur
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f11d3827a3df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gohup
+ pkgdesc = Command-line utility to run you program in background without any interruption.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/RishabhRD/gohup
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = sh
+ source = gohup-0.1.tar.gz::https://github.com/RishabhRD/gohup/archive/0.1.tar.gz
+ md5sums = aa983e963c000362e4bc2e279be65db8
+
+pkgname = gohup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79d0627ef569
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Rishabh Dwivedi <rishabhdwivedi17@gmail.com>
+pkgname=gohup
+pkgver=0.1
+pkgrel=1
+pkgdesc="Command-line utility to run you program in background without any interruption."
+arch=('i686' 'x86_64')
+url="https://github.com/RishabhRD/gohup"
+license=('GPLv3')
+depends=('sh')
+makedepends=('git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RishabhRD/gohup/archive/$pkgver.tar.gz")
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums=('aa983e963c000362e4bc2e279be65db8')