summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordenbeigh2018-02-12 21:08:47 -0800
committerdenbeigh2018-02-12 21:08:47 -0800
commit0d75cda1f2548122179d23ed04537f7ec0191a1c (patch)
treefd57dd8c644c5cb45b60f82af88b51574b47cff2
parenta0bdb23e48f9788074c0538d2c8f2d36f28775d9 (diff)
downloadaur-0d75cda1f2548122179d23ed04537f7ec0191a1c.tar.gz
Cleaned up PKGBUILD and versioning monstrosity
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88d2bbc5446c..50d16b917a93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = goi3bar-git
pkgdesc = A configurable, extensivle replacement for i3status written in Go
- pkgver = 026f1a
+ pkgver = r199.026f1a5
pkgrel = 1
url = https://github.com/denbeigh2000/goi3bar
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6259e240d08c..140928315e39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,19 @@
# Maintainer: Denbeigh Stevens <denbeigh at denbeighstevens dot com>
# Contributor: Denbeigh Stevens
+GITHUB_URL='github.com/denbeigh2000/goi3bar'
+
+pkgver() {
+ pushd "$GOPATH/src/$GITHUB_URL" >/dev/null
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ popd >/dev/null
+}
+
pkgname='goi3bar-git'
pkgrel=1
-pkgver=026f1a
+pkgver="$(pkgver)"
pkgdesc='A configurable, extensivle replacement for i3status written in Go'
-url='https://github.com/denbeigh2000/goi3bar'
+url="https://$GITHUB_URL"
arch=('x86_64' 'i686')
license=('GPL2')
conflicts=('goi3bar')
@@ -13,7 +21,7 @@ provides=('goi3bar')
depends=()
makedepends=('git' 'go>=1.5.0')
optdepends=('wireless_tools: WLAN plugin support')
-_gourl=github.com/denbeigh2000/goi3bar
+_gourl="$GITHUB_URL"
build() {
GOPATH="$srcdir" go get -u -v ${_gourl}/...