summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Vikstrom2015-09-10 11:21:28 +0200
committerSimon Vikstrom2015-09-10 11:24:10 +0200
commit345932f0b2b13d8c094ddcb362f9ea1a857c0f1d (patch)
tree7b38d3a6bd815ae4c06bae91fc21066feb370037
downloadaur-345932f0b2b13d8c094ddcb362f9ea1a857c0f1d.tar.gz
First package of goiardi chef-server
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--goiardi.service11
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21392f332559
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = goiardi
+ pkgdesc = A Chef server written in Go, able to run entirely in memory, with optional persistence with saving the in-memory data to disk or using MySQL or Postgres as the data storage backend
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = http://goiardi.gl/
+ arch = x86_64
+ license = Apache 2.0
+ source = https://github.com/ctdk/goiardi/releases/download/v0.10.0/goiardi-0.10.0-linux-amd64
+ source = goiardi.service
+ md5sums = 5fbd475a3f8c64681f9ace1f53212f78
+ md5sums = SKIP
+
+pkgname = goiardi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f691f2956a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=goiardi
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="A Chef server written in Go, able to run entirely in memory, with optional persistence with saving the in-memory data to disk or using MySQL or Postgres as the data storage backend"
+arch=('x86_64')
+license=('Apache 2.0')
+url="http://goiardi.gl/"
+source=(
+ https://github.com/ctdk/goiardi/releases/download/v$pkgver/goiardi-$pkgver-linux-amd64
+ goiardi.service
+ )
+
+md5sums=('5fbd475a3f8c64681f9ace1f53212f78'
+ 'SKIP'
+ )
+
+package() {
+ cd $srcdir
+ install -D -m755 $srcdir/goiardi-$pkgver-linux-amd64 $pkgdir/usr/bin/goiardi
+ install -D -m644 "${srcdir}/goiardi.service" "${pkgdir}/usr/lib/systemd/system/goiardi.service"
+}
diff --git a/goiardi.service b/goiardi.service
new file mode 100644
index 000000000000..51f46a88d673
--- /dev/null
+++ b/goiardi.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Goiardi server
+After=network.target nss-lookup.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/goiardi --conf-root /etc/goiardi
+LimitNOFILE=infinity
+
+[Install]
+WantedBy=multi-user.target