summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Araya Navarro2019-05-10 20:35:44 -0600
committerJorge Araya Navarro2019-05-10 20:35:44 -0600
commit074850d6fa1a553636f2866f14ed80fb09275c13 (patch)
tree8bfda8981a468be2b9db2333faab1335814dfbeb
parenta03e73c12d6a95836b75c0372d0ae81e2bf98358 (diff)
downloadaur-074850d6fa1a553636f2866f14ed80fb09275c13.tar.gz
fix: Changes on systemd unit service
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--goimapnotify@.service7
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f17cdaeefaab..4481b9592d8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 10 02:30:20 UTC 2019
+# Sat May 11 02:35:31 UTC 2019
pkgbase = goimapnotify
pkgdesc = Execute scripts on IMAP mailbox changes (new/deleted/updated messages) using IDLE, golang version.
pkgver = 2.0
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.com/shackra/goimapnotify
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = goimapnotify
source = https://gitlab.com/shackra/goimapnotify/repository/2.0/archive.tar.gz
source = goimapnotify@.service
sha256sums = 9a241d12a5b4cae12fe3d0b0bc5d376da228934f7f344d012e213ac184970471
- sha256sums = a6796c2b1ae3a03d096ad7755eaeb07ae33a5aa8ff32cca8b906fe0bbd67ba83
+ sha256sums = fad87eddc39f8ba2f7637024de96238cd9d5b0a7ce271ce75062127be74c1d0b
pkgname = goimapnotify
diff --git a/PKGBUILD b/PKGBUILD
index e0e05153f39a..87ac35d5e9c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jorge Araya Navarro <jorgejavieran@yahoo.com.mx>
pkgname=goimapnotify
pkgver=2.0
-pkgrel=3
+pkgrel=4
pkgdesc="Execute scripts on IMAP mailbox changes (new/deleted/updated messages) using IDLE, golang version."
arch=('i686' 'x86_64')
url="https://gitlab.com/shackra/goimapnotify"
@@ -11,7 +11,7 @@ options=('!strip' '!emptydirs')
source=("https://gitlab.com/shackra/goimapnotify/repository/${pkgver}/archive.tar.gz"
"goimapnotify@.service")
sha256sums=('9a241d12a5b4cae12fe3d0b0bc5d376da228934f7f344d012e213ac184970471'
- 'a6796c2b1ae3a03d096ad7755eaeb07ae33a5aa8ff32cca8b906fe0bbd67ba83')
+ 'fad87eddc39f8ba2f7637024de96238cd9d5b0a7ce271ce75062127be74c1d0b')
prepare() {
_dir=`find "$PWD" -iname "${pkgname}-${pkgver}-*" -type d`
diff --git a/goimapnotify@.service b/goimapnotify@.service
index c2ff632e2d9a..c52760cad8a2 100644
--- a/goimapnotify@.service
+++ b/goimapnotify@.service
@@ -1,12 +1,11 @@
[Unit]
Description=Execute scripts on IMAP mailbox changes (new/deleted/updated messages) using IDLE, golang version.
-Requires=network.target
-After=network.target
[Service]
-ExecStart=/usr/bin/goimapnotify -conf /home/%i/.config/imapnotify/%i.conf
+Type=simple
+ExecStart=/usr/bin/goimapnotify -conf %h/.config/imapnotify/%i.conf
Restart=always
RestartSec=30
[Install]
-WantedBy=multi-user.target
+WantedBy=default.target