summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTerin Stock2021-09-27 21:32:32 -0700
committerTerin Stock2021-09-27 21:32:32 -0700
commit1c6ca6b06a55e7aa3f612c53b72374e11735a326 (patch)
tree9f27415ddab46422635d7ada9c38578523c75e9a
parent4be22c7e905cea7e62a92e3f6380ad4c99c2d585 (diff)
downloadaur-1c6ca6b06a55e7aa3f612c53b72374e11735a326.tar.gz
gojq: 0.12.1 -> 0.12.5
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 141fbe1e4d76..d122ed1f2bef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = gojq
pkgdesc = Pure go implementation of jq
- pkgver = 0.12.1
+ pkgver = 0.12.5
pkgrel = 1
url = https://github.com/itchyny/gojq
arch = x86_64
license = MIT
makedepends = go
depends = glibc
- source = gojq-0.12.1.tar.gz::https://github.com/itchyny/gojq/archive/v0.12.1.tar.gz
- sha256sums = 174681da4c54edde43c25c745f1a9d7d13864149af67a9f0773945e8485b1532
+ source = gojq-0.12.5.tar.gz::https://github.com/itchyny/gojq/archive/v0.12.5.tar.gz
+ sha256sums = 69616c38cc9bcdef06d32692e1cc1f330980c523fc777b07a851a52b51fffdac
pkgname = gojq
-
diff --git a/PKGBUILD b/PKGBUILD
index 4e399d5c7138..22aae1426bf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Terin Stock <terinjokes@gmail.com>
pkgname=gojq
-pkgver=0.12.1
+pkgver=0.12.5
+_pkgrev=727b4b5
pkgrel=1
pkgdesc='Pure go implementation of jq'
arch=('x86_64')
@@ -10,7 +11,7 @@ license=('MIT')
makedepends=('go')
depends=('glibc')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/itchyny/gojq/archive/v${pkgver}.tar.gz")
-sha256sums=('174681da4c54edde43c25c745f1a9d7d13864149af67a9f0773945e8485b1532')
+sha256sums=('69616c38cc9bcdef06d32692e1cc1f330980c523fc777b07a851a52b51fffdac')
prepare(){
cd "${pkgname}-${pkgver}"
@@ -23,8 +24,8 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
- go build -o build ./cmd/gojq
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build -ldflags="-X github.com/itchyny/gojq/cli.revision=${_pkgrev}" ./cmd/gojq
}
check() {