summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-12 19:45:36 +0300
committerDimitris Kiziridis2020-05-12 19:45:36 +0300
commit144ace5acf07e62e9c5cb00064231bdc1827049f (patch)
treeca15a20e5915be2fc04b46020f866ae07a6fba5b
parent91dc2c71a9e39714e060d3481a8e9d4ff47b90fd (diff)
downloadaur-144ace5acf07e62e9c5cb00064231bdc1827049f.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bee78c0c13e..28989925e66d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,8 @@ pkgbase = gokit-cli-bin
license = MIT
provides = gokit
provides = gokit-cli
- source = https://github.com/kujtimiihoxha/kit/releases/download/v0.1.1/kit_0.1.1_Linux_x86_64.tar.gz
- md5sums = 730548d8733a12317661b9e0b945985e
+ source = gokit-cli-bin-0.1.1.tar.gz::https://github.com/kujtimiihoxha/kit/releases/download/v0.1.1/kit_0.1.1_Linux_x86_64.tar.gz
+ sha256sums = 651dd22917db7bea23d859cd2800ef5b6080a260039234323e72e08e1025639f
pkgname = gokit-cli-bin
diff --git a/PKGBUILD b/PKGBUILD
index 60a8b497a494..35bbf788f89d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ arch=('x86_64')
url="https://github.com/kujtimiihoxha/kit"
license=('MIT')
provides=('gokit' 'gokit-cli')
-source=("${url}/releases/download/v${pkgver}/kit_${pkgver}_Linux_x86_64.tar.gz")
-md5sums=('730548d8733a12317661b9e0b945985e')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/kit_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('651dd22917db7bea23d859cd2800ef5b6080a260039234323e72e08e1025639f')
package() {
install -Dm755 "${srcdir}"/kit "${pkgdir}/usr/bin/kit"
- install -Dm644 "${srcdir}"/LICENCE "${pkgdir}/usr/share/licenses/gokit/LICENSE"
+ install -Dm644 "${srcdir}"/LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file