summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2019-10-31 14:13:10 +0100
committerfrederik2019-10-31 14:13:10 +0100
commit45ebe12090240417ba252ef3a6e75d0f91c8c969 (patch)
tree94bd103f9a77f38d6009b824186aba365930c189
parent3bce5c758336bad25793a4dbe74b7726159ffdf5 (diff)
downloadaur-45ebe12090240417ba252ef3a6e75d0f91c8c969.tar.gz
goland: PKGBUILD review by svenstaro
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a0ea7e6d230..2f017cc66b50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = goland
- pkgdesc = Capable and Ergonomic Go IDE
pkgver = 2019.2.3
pkgrel = 1
url = https://www.jetbrains.com/go/
arch = x86_64
arch = i686
license = Commercial
- makedepends = rsync
options = !strip
source = https://download.jetbrains.com/go/goland-2019.2.3.tar.gz
source = jetbrains-goland.desktop
@@ -14,12 +12,15 @@ pkgbase = goland
sha512sums = 930a0f1269b7f49f7a08fd5fbfff178628114dee01f4e4e8426c643d7c442b77f178b5188325caf0ace5503c5f873a419cd3f7128b63d7c3c9baf8065b0065aa
pkgname = goland
+ pkgdesc = Capable and Ergonomic Go IDE
optdepends = goland-jre: JetBrains custom Java Runtime (Recommended)
optdepends = java-runtime: JRE - Required if goland-jre is not installed
conflicts = gogland
replaces = gogland
pkgname = goland-jre
+ pkgdesc = JBR (JetBrains Runtime) for Goland - a patched JDK
+ url = https://confluence.jetbrains.com/display/JBR/JetBrains+Runtime
conflicts = gogland-jre
replaces = gogland-jre
diff --git a/PKGBUILD b/PKGBUILD
index 948ba4758fad..f6703eeebb6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,9 @@ pkgbase=goland
pkgname=(goland goland-jre)
pkgver=2019.2.3
pkgrel=1
-pkgdesc='Capable and Ergonomic Go IDE'
arch=('x86_64' 'i686')
url='https://www.jetbrains.com/go/'
license=('Commercial')
-makedepends=('rsync')
options=('!strip')
source=(https://download.jetbrains.com/go/${pkgbase}-${pkgver}.tar.gz
jetbrains-goland.desktop)
@@ -16,27 +14,31 @@ sha512sums=('6e82c7aeb28e25f787a99046d5e517534f5a441a1e8c1051ec2fa629a2fc61d12b1
'930a0f1269b7f49f7a08fd5fbfff178628114dee01f4e4e8426c643d7c442b77f178b5188325caf0ace5503c5f873a419cd3f7128b63d7c3c9baf8065b0065aa')
package_goland() {
+ pkgdesc='Capable and Ergonomic Go IDE'
optdepends=('goland-jre: JetBrains custom Java Runtime (Recommended)'
'java-runtime: JRE - Required if goland-jre is not installed')
conflicts=('gogland')
replaces=('gogland')
- install -d -m 755 "${pkgdir}/opt/"
- install -d -m 755 "${pkgdir}/usr/bin/"
- install -d -m 755 "${pkgdir}/usr/share/applications/"
- install -d -m 755 "${pkgdir}/usr/share/pixmaps/"
+ install -dm755 "${pkgdir}"/opt/
+ install -dm755 "${pkgdir}"/usr/bin/
+ install -dm755 "${pkgdir}"/usr/share/applications/
+ install -dm755 "${pkgdir}"/usr/share/pixmaps/
- rsync -rtl "${srcdir}/GoLand-${pkgver}/" "${pkgdir}/opt/${pkgbase}" --exclude=/jbr
+ cp -a "${srcdir}"/GoLand-${pkgver}/ "${pkgdir}"/opt/${pkgbase}
+ rm -rf "${pkgdir}"/opt/${pkgbase}/jbr
- ln -s "/opt/${pkgbase}/bin/${pkgbase}.sh" "${pkgdir}/usr/bin/${pkgbase}"
- install -D -m 644 "${srcdir}/jetbrains-${pkgbase}.desktop" "${pkgdir}/usr/share/applications/"
- install -D -m 644 "${pkgdir}/opt/${pkgbase}/bin/${pkgbase}.png" "${pkgdir}/usr/share/pixmaps/${pkgbase}.png"
+ ln -s /opt/${pkgbase}/bin/${pkgbase}.sh "${pkgdir}"/usr/bin/${pkgbase}
+ install -m644 "${srcdir}"/jetbrains-${pkgbase}.desktop "${pkgdir}"/usr/share/applications/
+ install -m644 "${pkgdir}"/opt/${pkgbase}/bin/${pkgbase}.png "${pkgdir}"/usr/share/pixmaps/${pkgbase}.png
}
package_goland-jre() {
+ pkgdesc='JBR (JetBrains Runtime) for Goland - a patched JDK'
+ url='https://confluence.jetbrains.com/display/JBR/JetBrains+Runtime'
conflicts=('gogland-jre')
replaces=('gogland-jre')
- install -d -m 755 "${pkgdir}/opt/${pkgbase}"
- rsync -rtl "${srcdir}/GoLand-${pkgver}/jbr" "${pkgdir}/opt/${pkgbase}"
+ install -dm755 "${pkgdir}"/opt/${pkgbase}
+ cp -a "${srcdir}"/GoLand-${pkgver}/jbr "${pkgdir}"/opt/${pkgbase}
}