summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-05-30 20:30:51 +0200
committerMarcell Meszaros2022-05-30 20:32:20 +0200
commit53d601cbd9891f87009e517992a1ef8c57cba746 (patch)
tree82a57c0b7875997e4ec346eac6615b08def5c551
parent75221b189794bdeef355540e2b556de0d90bbda2 (diff)
downloadaur-53d601cbd9891f87009e517992a1ef8c57cba746.tar.gz
rename to golang-glide-bin
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9ed6a28e8e7..5b5d613b1a0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
-pkgbase = glide-bin
- pkgdesc = Dependency management and vendoring for Go projects
+pkgbase = golang-glide-bin
+ pkgdesc = Legacy dependency management and vendoring for Go projects
pkgver = 0.13.3
pkgrel = 1
url = https://github.com/Masterminds/glide
arch = x86_64
license = MIT
- provides = glide
- source = https://github.com/Masterminds/glide/releases/download/v0.13.3/glide-v0.13.3-linux-amd64.tar.gz
- sha256sums = ba5619955a28d7931a9ae38d095fc5fa5acc28e77abc8737a8136c652d9cbb38
-
-pkgname = glide-bin
+ provides = golang-glide=0.13.3
+ provides = glide=0.13.3
+ provides = glide-bin
+ conflicts = glide
+ conflicts = glide-bin
+ conflicts = golang-glide
+ replaces = glide-bin
+ options = !strip
+ source = golang-glide-bin-v0.13.3-linux-amd64.tar.gz::https://github.com/Masterminds/glide/releases/download/v0.13.3/glide-v0.13.3-linux-amd64.tar.gz
+ b2sums = 78563a6894d8bf4adce3458cc7ecc4b64137eeecec92db3853f3cdb5586aa277618b9cd9bff7074734a5981b598d559b34c30c2c18c58cc3b47026b362077939
+pkgname = golang-glide-bin
diff --git a/PKGBUILD b/PKGBUILD
index cf8d91bbf7a7..0cbeae7c6424 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
-# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Lukas Grossar <lukas.grossar@gmail.com>
-pkgname=glide-bin
+pkgname=golang-glide-bin
_pkgname=glide
-pkgdesc="Dependency management and vendoring for Go projects"
+pkgdesc='Legacy dependency management and vendoring for Go projects'
pkgver=0.13.3
pkgrel=1
arch=('x86_64')
-url="https://github.com/Masterminds/glide"
+url="https://github.com/Masterminds/${_pkgname}"
license=('MIT')
-provides=('glide')
-source=("https://github.com/Masterminds/glide/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux-amd64.tar.gz")
-sha256sums=('ba5619955a28d7931a9ae38d095fc5fa5acc28e77abc8737a8136c652d9cbb38')
+provides=("${pkgname%-bin}=${pkgver}" "glide=${pkgver}" 'glide-bin')
+conflicts=('glide' 'glide-bin' "${pkgname%-bin}")
+replaces=('glide-bin')
+options=('!strip')
+source=("${pkgname}-v${pkgver}-linux-amd64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-linux-amd64.tar.gz")
+b2sums=('78563a6894d8bf4adce3458cc7ecc4b64137eeecec92db3853f3cdb5586aa277618b9cd9bff7074734a5981b598d559b34c30c2c18c58cc3b47026b362077939')
package() {
- install -Dm 755 "$srcdir/linux-amd64/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ pushd "$srcdir/linux-amd64"
+ install -Dm 755 "${_pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname%-bin}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ popd
}