summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-05-14 03:14:21 +0200
committerml2020-05-14 03:14:21 +0200
commit3968694a1444d5ab993f63de22b424350956b165 (patch)
tree09d3aa2ee7bdb0d4dbfbcd93f7ccf8f4fce4fc2f
parent2be7b6399eaae23529fa9d24b9fe5a63d0c9e9af (diff)
downloadaur-3968694a1444d5ab993f63de22b424350956b165.tar.gz
upgpkg: golangci-lint 1.27.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d6a868ded96..1ead4db5df4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = golangci-lint
pkgdesc = Linters Runner for Go. 5x faster than gometalinter.
- pkgver = 1.26.0
+ pkgver = 1.27.0
pkgrel = 1
url = https://github.com/golangci/golangci-lint
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = golangci-lint
makedepends = go
makedepends = gzip
depends = glibc
- source = golangci-lint-1.26.0.tar.gz::https://github.com/golangci/golangci-lint/archive/v1.26.0.tar.gz
- sha256sums = fac66b685253d76625c18177e03d36bca0a5dac52a0c3978fc96daad07bcb704
+ source = golangci-lint-1.27.0.tar.gz::https://github.com/golangci/golangci-lint/archive/v1.27.0.tar.gz
+ sha256sums = 11a23b60416cab57a7d83c97d723212ec3c430c4d9fdfc698e5f5276cd5ac15a
pkgname = golangci-lint
diff --git a/PKGBUILD b/PKGBUILD
index 6228da1fe233..08124546499d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Matthias Lisin <ml@visu.li>
pkgname=golangci-lint
pkgdesc="Linters Runner for Go. 5x faster than gometalinter."
-pkgver=1.26.0
+pkgver=1.27.0
pkgrel=1
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url='https://github.com/golangci/golangci-lint'
@@ -9,7 +9,7 @@ license=('GPL3')
depends=('glibc')
makedepends=('git' 'go' 'gzip')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/golangci/golangci-lint/archive/v${pkgver}.tar.gz")
-sha256sums=('fac66b685253d76625c18177e03d36bca0a5dac52a0c3978fc96daad07bcb704')
+sha256sums=('11a23b60416cab57a7d83c97d723212ec3c430c4d9fdfc698e5f5276cd5ac15a')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -40,7 +40,7 @@ check() {
# CGO_CFLAGS break tests when run inside ~/.cache (yay).
# TODO investigate
unset CGO_CFLAGS
- GOLANGCI_LINT_INSTALLED=true go test ./...
+ GL_TEST_RUN=1 GOLANGCI_LINT_INSTALLED=true go test ./...
}
package() {