summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-11-27 01:00:41 +0100
committerml2020-11-27 01:00:43 +0100
commit7a3f03feb7bf8db5a63acc4fc6625f9f15520e1e (patch)
tree6f32b8318459b55eace611ed2adef0c0eaeb4f38
parent9b48de4ac3d66a63b630a4b541d9316a3ce0be5e (diff)
downloadaur-7a3f03feb7bf8db5a63acc4fc6625f9f15520e1e.tar.gz
updpkg: golangci-lint 1.33.0-2
Implicitly fetch dependencies with on `go build'. `go mod download' fetches full modules which is a waste of disk space (~500M). `go get -d' would be the better way to prefetch dependencies in prepare(), however does not work for golangci-lint. Upstream doesn't seem to care about this inconsistency. No point in punishing users not having access to a fast internet connection or have little disk space.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 2 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86ede06afbd4..79699f3e2570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = golangci-lint
pkgdesc = Linters Runner for Go. 5x faster than gometalinter.
pkgver = 1.33.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/golangci/golangci-lint
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 412387816ae7..318fac4353ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=golangci-lint
pkgdesc="Linters Runner for Go. 5x faster than gometalinter."
pkgver=1.33.0
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url='https://github.com/golangci/golangci-lint'
license=('GPL3')
@@ -11,11 +11,6 @@ makedepends=('git' 'go')
source=("https://github.com/golangci/golangci-lint/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('ae828754b1f9b0cee11cc81f0720f187831bc61d7b7cbb6e80421ff2d5b74631')
-prepare() {
- cd "${pkgname}-${pkgver}"
- go mod download
-}
-
build() {
local _commit _flags
_commit=$(bsdcat "${pkgname}-${pkgver}.tar.gz" | git get-tar-commit-id)