summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2021-05-14 16:18:45 +0200
committerml2021-05-14 16:18:45 +0200
commitc4313a0ae9ddcaa990d18b3187304f1b70c352bd (patch)
tree31c0541c102e200ecc016e4da507d004fbf2249c
parent2717320f13372f76e6cab669dc84a4d755c873a9 (diff)
downloadaur-c4313a0ae9ddcaa990d18b3187304f1b70c352bd.tar.gz
updpkg: golangci-lint 1.40.1-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20a2ffe72767..6fbe09fb9390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = golangci-lint
pkgdesc = Linters Runner for Go. 5x faster than gometalinter.
- pkgver = 1.40.0
+ pkgver = 1.40.1
pkgrel = 1
url = https://github.com/golangci/golangci-lint
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = golangci-lint
makedepends = git
makedepends = go
depends = glibc
- source = https://github.com/golangci/golangci-lint/archive/v1.40.0/golangci-lint-1.40.0.tar.gz
- sha256sums = 15454b587e6836325e9446ed2799bde39ae766aeae24efe362f661a3e85c84ec
+ source = https://github.com/golangci/golangci-lint/archive/v1.40.1/golangci-lint-1.40.1.tar.gz
+ sha256sums = e399d085319d7d2ef1f2db3f5d854101585ad652fbf22286e892bdc57a87c2a1
pkgname = golangci-lint
diff --git a/PKGBUILD b/PKGBUILD
index 82eab99bfafc..e769c94d6b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <ml@visu.li>
pkgname=golangci-lint
pkgdesc="Linters Runner for Go. 5x faster than gometalinter."
-pkgver=1.40.0
+pkgver=1.40.1
pkgrel=1
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url='https://github.com/golangci/golangci-lint'
@@ -9,7 +9,7 @@ license=('GPL3')
depends=('glibc')
makedepends=('git' 'go')
source=("https://github.com/golangci/golangci-lint/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('15454b587e6836325e9446ed2799bde39ae766aeae24efe362f661a3e85c84ec')
+sha256sums=('e399d085319d7d2ef1f2db3f5d854101585ad652fbf22286e892bdc57a87c2a1')
build() {
local _commit _flags
@@ -30,16 +30,7 @@ build() {
go build -o "$pkgname" -ldflags="${_flags[*]}" ./cmd/"$pkgname"
}
-# breaks for yay users
-#check() {
-# cd "${pkgname}-${pkgver}"
-# # some tests build the binary and overwrite our build
-# chmod 555 "$pkgname" # canary
-# # CGO_CFLAGS break tests when run inside ~/.cache (yay).
-# # TODO investigate
-# unset CGO_CFLAGS CGO
-# GL_TEST_RUN=1 GOLANGCI_LINT_INSTALLED=true go test ./...
-#}
+# @TODO check()
package() {
cd "${pkgname}-${pkgver}"