summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry Smith2022-07-25 17:49:09 +0100
committerHenry Smith2022-07-25 17:49:09 +0100
commitd0c25af83a27f3e94fe47711f63d4ea34598b957 (patch)
tree0ed3c680b7ae3fa168b26272d9e108a700027b4c
parente105a1eb59ee94541271aac459bb3843d7b9952d (diff)
downloadaur-d0c25af83a27f3e94fe47711f63d4ea34598b957.tar.gz
Fix PKGBUILD
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a1b8739f850..06f2d16ec3ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=golaunch
pkgver=0.7
-pkgrel=1
+pkgrel=2
pkgdesc='a simple .desktop launcher written in go.'
arch=('x86_64')
url="https://github.com/hen6003/golaunch"
@@ -12,6 +12,9 @@ source=("https://github.com/hen6003/golaunch/archive/$pkgver.tar.gz")
sha256sums=('7c9de9c52dd08b04aab0fa2b5738ba28d452a7bb42d777636132c19a1199c84c')
prepare() {
+ go mod init main
+ go mod tidy
+
go get -u \
github.com/rkoesters/xdg/basedir \
github.com/rkoesters/xdg/desktop
@@ -19,8 +22,6 @@ prepare() {
build() {
cd "$pkgname"-"$pkgver"
- go mod init main
- go mod tidy
cd golaunch
go build -gcflags "all=-trimpath=$PWD" \