summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Cook2024-03-17 16:22:00 -0500
committerTyler Cook2024-03-17 16:22:00 -0500
commit7da3207fe8198b123e73d61ff525760e632964b9 (patch)
treeca63fc3a5e81d89ef7fd2e79a45cac10949041de
parente1c1f541019befaba82c52a0b55c7773147b26b6 (diff)
downloadaur-7da3207fe8198b123e73d61ff525760e632964b9.tar.gz
chore: bump version
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12b38fd2753a..ddb6141325da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = goldboot
pkgdesc = Immutable infrastructure for the desktop!
- pkgver = 0.0.1
+ pkgver = 0.0.2
pkgrel = 1
url = https://github.com/fossable/goldboot
arch = x86_64
@@ -8,7 +8,8 @@ pkgbase = goldboot
makedepends = cargo
depends = edk2-ovmf
depends = qemu-base
- source = goldboot-0.0.1.tar.gz::https://static.crates.io/crates/goldboot/goldboot-0.0.1.crate
+ depends = qemu-ui-gtk
+ source = goldboot-0.0.2.tar.gz::https://static.crates.io/crates/goldboot/goldboot-0.0.2.crate
sha512sums = SKIP
pkgname = goldboot
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f7f3019d656
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+src
diff --git a/PKGBUILD b/PKGBUILD
index 27b9f5640afc..4c535fc218c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Tyler Cook <aur@fossable.org>
pkgdesc='Immutable infrastructure for the desktop!'
pkgname='goldboot'
-pkgver='0.0.1'
+pkgver='0.0.2'
pkgrel='1'
url='https://github.com/fossable/goldboot'
arch=('x86_64')
license=('GNU Affero General Public License v3.0')
-depends=('edk2-ovmf' 'qemu-base')
+depends=('edk2-ovmf' 'qemu-base' 'qemu-ui-gtk')
makedepends=('cargo')
-source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+source=("goldboot-$pkgver.tar.gz::https://static.crates.io/crates/goldboot/goldboot-$pkgver.crate")
sha512sums=('SKIP')
prepare() {
@@ -19,12 +19,12 @@ prepare() {
build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- cargo build --frozen --release --no-default-features --features cast
+ cargo build --bin goldboot --frozen --release
}
check() {
export RUSTUP_TOOLCHAIN=stable
- cargo test --frozen --all-features
+ cargo test --bin goldboot --frozen --all-features
}
package() {