summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Cook2024-03-16 14:57:54 -0500
committerTyler Cook2024-03-16 14:57:54 -0500
commite1c1f541019befaba82c52a0b55c7773147b26b6 (patch)
tree03c3d4698a2c19536c49eb4248dde40d3c9c626d
downloadaur-e1c1f541019befaba82c52a0b55c7773147b26b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12b38fd2753a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = goldboot
+ pkgdesc = Immutable infrastructure for the desktop!
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/fossable/goldboot
+ arch = x86_64
+ license = GNU Affero General Public License v3.0
+ makedepends = cargo
+ depends = edk2-ovmf
+ depends = qemu-base
+ source = goldboot-0.0.1.tar.gz::https://static.crates.io/crates/goldboot/goldboot-0.0.1.crate
+ sha512sums = SKIP
+
+pkgname = goldboot
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27b9f5640afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tyler Cook <aur@fossable.org>
+pkgdesc='Immutable infrastructure for the desktop!'
+pkgname='goldboot'
+pkgver='0.0.1'
+pkgrel='1'
+url='https://github.com/fossable/goldboot'
+arch=('x86_64')
+license=('GNU Affero General Public License v3.0')
+depends=('edk2-ovmf' 'qemu-base')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+sha512sums=('SKIP')
+
+prepare() {
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --no-default-features --features cast
+}
+
+check() {
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}